Page MenuHome

Warning! Legacy WGL is unable to select between different OpenGL versions
Closed, ResolvedPublic

Description

System Information
CPU: Intel Pentium Dual Core 1.87Ghz (Merom)
RAM: 2.75Gb
GFX: ATI Radeon X1250, 256Mb
OS: Windows 7 Ultimate 32 bit
Drivers: I don't know.
Blender: 2.77a

Blender Version
Broken: 2.77a abf6f08
Worked: 2.76b I don't know the hash, it was the official one at blender.org.

Short description of error
When I open blender, whether I open the program or open a blend file with the program, the popup says Warning! Legacy WGL is unable to select between different OpenGL versions.

Exact steps for others to reproduce the error

  1. Open blender.
  2. On the cmd screen that appears at startup, it says Warning! Legacy WGL is unable to select between different OpenGL versions.

Other notes:
I think that I'm not the only person facing this issue. Please check the following two questions at blender.stackexchange.com.
I posted http://blender.stackexchange.com/questions/51653/warning-legacy-wgl-is-unable-to-select-between-different-opengl-versions
This is by another person: http://blender.stackexchange.com/questions/51905/legacy-wgl-is-unable-to-select-between-opengl-versions-error

Details

Type
Bug

Event Timeline

Yubin Lee (jordanyubin) raised the priority of this task from to Needs Triage by Developer.
Yubin Lee (jordanyubin) updated the task description. (Show Details)
Yubin Lee (jordanyubin) set Type to Bug.

This is a screenshot.

And the following is the system-info.txt.

Blender 2.77 (sub 0) System Information

Blender:

version: 2.77 (sub 0), branch: master, commit date: 2016-04-05 18:12, hash: abf6f08, type:
build date: Wed 04/06/2016, 10:13 AM
platform: Windows
binary path: 'C:\\Users\\chef\\Downloads\\유빈\\blender-2.77a-windows32\\blender.exe'
build cflags: /W3 /w34062 /wd4018 /wd4146 /wd4065 /wd4127 /wd4181 /wd4200 /wd4244 /wd4267 /wd4305 /wd4800 /we4013 /we4431 /DWIN32 /D_WINDOWS /W3 /nologo /J /Gd /MP /openmp /arch:SSE2 /arch:SSE
build cxxflags: /W3 /w34062 /wd4018 /wd4146 /wd4065 /wd4127 /wd4181 /wd4200 /wd4244 /wd4267 /wd4305 /wd4800 /we4013 /we4431 /DWIN32 /D_WINDOWS /W3 /GR /EHsc /nologo /J /Gd /MP /EHsc /openmp /arch:SSE2 /arch:SSE
build linkflags: /MACHINE:IX86 /LARGEADDRESSAWARE /SUBSYSTEM:CONSOLE /STACK:2097152 /INCREMENTAL:NO /NODEFAULTLIB:msvcrt.lib /NODEFAULTLIB:msvcmrt.lib /NODEFAULTLIB:msvcurt.lib /NODEFAULTLIB:msvcrtd.lib /ignore:4049 /ignore:4217 /ignore:4221 /DELAYLOAD:vcomp120.dll delayimp.lib
build system: CMake

Python:

version: 3.5.1 (default, Feb 18 2016, 08:21:03) [MSC v.1800 32 bit (Intel)]
paths:
'C:\\Users\\chef\\Downloads\\유빈\\blender-2.77a-windows32\\2.77\\scripts\\addons_contrib'
'C:\\Users\\chef\\AppData\\Roaming\\Blender Foundation\\Blender\\2.77\\scripts\\addons'
'C:\\Users\\chef\\Downloads\\유빈\\blender-2.77a-windows32\\2.77\\scripts\\addons'
'C:\\Users\\chef\\Downloads\\유빈\\blender-2.77a-windows32\\2.77\\scripts\\startup'
'C:\\Users\\chef\\Downloads\\유빈\\blender-2.77a-windows32\\2.77\\scripts\\modules'
'C:\\Users\\chef\\Downloads\\유빈\\blender-2.77a-windows32\\python35.zip'
'C:\\Users\\chef\\Downloads\\유빈\\blender-2.77a-windows32\\2.77\\python\\DLLs'
'C:\\Users\\chef\\Downloads\\유빈\\blender-2.77a-windows32\\2.77\\python\\lib'
'C:\\Users\\chef\\Downloads\\유빈\\blender-2.77a-windows32'
'C:\\Users\\chef\\Downloads\\유빈\\blender-2.77a-windows32\\2.77\\python'
'C:\\Users\\chef\\Downloads\\유빈\\blender-2.77a-windows32\\2.77\\python\\lib\\site-packages'
'C:\\Users\\chef\\Downloads\\유빈\\blender-2.77a-windows32\\2.77\\scripts\\freestyle\\modules'
'C:\\Users\\chef\\Downloads\\유빈\\blender-2.77a-windows32\\2.77\\scripts\\addons\\modules'
'C:\\Users\\chef\\AppData\\Roaming\\Blender Foundation\\Blender\\2.77\\scripts\\addons\\modules'

Python (External Binary):

binary path: 'C:\\Users\\chef\\Downloads\\유빈\\blender-2.77a-windows32\\2.77\\python\\bin\\python.EXE'
version: Python 3.5.1

Directories:

scripts:
'C:\\Users\\chef\\Downloads\\유빈\\blender-2.77a-windows32\\2.77\\scripts\\modules'
'C:\\Users\\chef\\Downloads\\유빈\\blender-2.77a-windows32\\2.77\\scripts'
'C:\\Users\\chef\\AppData\\Roaming\\Blender Foundation\\Blender\\2.77\\scripts'
user scripts: 'C:\\Users\\chef\\AppData\\Roaming\\Blender Foundation\\Blender\\2.77\\scripts'
pref scripts: None
datafiles: 'C:\\Users\\chef\\AppData\\Roaming\\Blender Foundation\\Blender\\2.77\\datafiles\\'
config: 'C:\\Users\\chef\\AppData\\Roaming\\Blender Foundation\\Blender\\2.77\\config\\'
scripts : 'C:\\Users\\chef\\AppData\\Roaming\\Blender Foundation\\Blender\\2.77\\scripts\\'
autosave: 'C:\\Users\\chef\\AppData\\Roaming\\Blender Foundation\\Blender\\2.77\\autosave\\'
tempdir: 'C:\\Users\\chef\\AppData\\Local\\Temp\\blender_a02012\\'

FFmpeg:

avcodec: '55, 39, 101'
avdevice: '55, 5, 100'
avformat: '55, 19, 104'
avutil: '52, 48, 101'
swscale: ' 2, 5, 101'

SDL:

Version: 2.0.3
Loading method: linked (WITH_SDL_DYNLOAD=OFF)

Other Libraries:

OpenColorIO: 0, 0, 0
OpenImageIO: 1, 6, 9
OpenShadingLanguage: 1, 7, 1
OpenVDB: 3, 1, 0

OpenGL:

renderer: 'ATI Radeon Xpress 1200 Series '
vendor: 'ATI Technologies Inc.'
version: '2.1.8304 Release'
extensions:
GL_AMD_performance_monitor
GL_ARB_depth_texture
GL_ARB_draw_buffers
GL_ARB_fragment_program
GL_ARB_fragment_program_shadow
GL_ARB_fragment_shader
GL_ARB_half_float_pixel
GL_ARB_half_float_vertex
GL_ARB_multisample
GL_ARB_multitexture
GL_ARB_occlusion_query
GL_ARB_pixel_buffer_object
GL_ARB_point_parameters
GL_ARB_point_sprite
GL_ARB_shader_objects
GL_ARB_shading_language_100
GL_ARB_shadow
GL_ARB_shadow_ambient
GL_ARB_texture_border_clamp
GL_ARB_texture_compression
GL_ARB_texture_cube_map
GL_ARB_texture_env_add
GL_ARB_texture_env_combine
GL_ARB_texture_env_crossbar
GL_ARB_texture_env_dot3
GL_ARB_texture_float
GL_ARB_texture_mirrored_repeat
GL_ARB_texture_non_power_of_two
GL_ARB_texture_rectangle
GL_ARB_transpose_matrix
GL_ARB_vertex_buffer_object
GL_ARB_vertex_program
GL_ARB_vertex_shader
GL_ARB_window_pos
GL_ATI_draw_buffers
GL_ATI_envmap_bumpmap
GL_ATI_fragment_shader
GL_ATI_meminfo
GL_ATI_separate_stencil
GL_ATI_texture_compression_3dc
GL_ATI_texture_env_combine3
GL_ATI_texture_float
GL_EXT_abgr
GL_EXT_bgra
GL_EXT_blend_color
GL_EXT_blend_equation_separate
GL_EXT_blend_func_separate
GL_EXT_blend_minmax
GL_EXT_blend_subtract
GL_EXT_compiled_vertex_array
GL_EXT_copy_texture
GL_EXT_draw_range_elements
GL_EXT_fog_coord
GL_EXT_framebuffer_blit
GL_EXT_framebuffer_multisample
GL_EXT_framebuffer_object
GL_EXT_gpu_program_parameters
GL_EXT_multi_draw_arrays
GL_EXT_packed_depth_stencil
GL_EXT_packed_pixels
GL_EXT_point_parameters
GL_EXT_rescale_normal
GL_EXT_secondary_color
GL_EXT_separate_specular_color
GL_EXT_shadow_funcs
GL_EXT_stencil_wrap
GL_EXT_subtexture
GL_EXT_texgen_reflection
GL_EXT_texture3D
GL_EXT_texture_compression_s3tc
GL_EXT_texture_cube_map
GL_EXT_texture_edge_clamp
GL_EXT_texture_env_add
GL_EXT_texture_env_combine
GL_EXT_texture_env_dot3
GL_EXT_texture_filter_anisotropic
GL_EXT_texture_lod_bias
GL_EXT_texture_mirror_clamp
GL_EXT_texture_object
GL_EXT_texture_rectangle
GL_EXT_texture_sRGB
GL_EXT_vertex_array
GL_KTX_buffer_region
GL_NV_blend_square
GL_NV_texgen_reflection
GL_SGIS_generate_mipmap
GL_SGIS_texture_edge_clamp
GL_SGIS_texture_lod
GL_WIN_swap_hint
WGL_EXT_swap_control

Implementation Dependent OpenGL Limits:

Maximum Fixed Function Texture Units: 8
Maximum DrawElements Vertices: 2147483647
Maximum DrawElements Indices: 16384

GLSL:
Maximum Varying Floats: 44
Maximum Vertex Attributes: 16
Maximum Vertex Uniform Components: 512
Maximum Fragment Uniform Components: 512
Maximum Vertex Image Units: 0
Maximum Fragment Image Units: 16
Maximum Pipeline Image Units: 16

Cycles:

CPU device capabilities: SSE2 SSE3

Aaron Carlisle (Blendify) claimed this task.

Your GPU is too old. You may be able to still use it if you update your drivers.

Will there be any issue such as slower render times or malfunctioning 3d viewport? will it affect rendering even though I use cpu rendering?

If you are able to get it to open with a newer driver it should not affect you.

If I stay with this driver, will these be affected(this gpu is old(for vista), and has no "official" drivers for 7)?
Also, will I not be able to use future versions of blender?

No, the OpenGL required version is only going to increase. Blender 2.8 will likely be OpenGL 3.X. Currently, you have to have at least OpenGL 2.1 see the requirements page for more information https://www.blender.org/download/requirements/

Chip Cooper (Cyberchip) reopened this task as Open.EditedSep 1 2016, 4:49 PM

Please explain how Blender running on a GPU that supports OpenGL 2.1 and ran fine on Windows 7 gives this error on Windows 10 Anniversary edition if GPU is too old? Therefore this is not a satisfactory answer.

Contacted Nvidia and they insist, and I agree that GPU is 'not' too old, and ran Blender just fine on Windows 7. Nvidia also stated that since it ran on Windows 7, and that OpenGL support is hardware based, driver is not the cause, and the application (Blender) is the offender.

I question this because Blender ran fine with same card on Windows 7. Because only three things changed on my system. Windows 7 to Windows 10 Anniversary upgrade, NVidia drivers were updated (clean install) from Windows 7 to those for Windows 10, and Blender was updated since previous version failed, this points to some kind of software change, none of my other applications are affected; and I run some intense graphics applications, including Blender!

To me, it seems as if this is a Windows 10 problem then; but, I can find nothing to support this. So what we have right now is Nvidia pointing at Blender.org, Blender pointing at GPU and Windows 10 saying "what me worry?" Until this issue is resolved, this should remain open. We need to determine exactly where to point the finger. I'll try to coordinate. If Blender and Nvidia can work to help me understand why I should point my finger at Windows, I will work to help resolve this issue. I miss using Blender, and it appears many do have this problem, but are unorganized. (Probably because they don't know where to look for help; and to date, I've seen no one claim any uninstall and re-install of graphics drivers works! I know, I've done it twice already myself with everything except Windows 10 because with Windows 10, that's not possible.

I will attempt to display OpenGL Viewer 4.4.4 image of OpenGL support of version 2.1 by my "NOT" too old GPU.

Sergey Sharybin (sergey) lowered the priority of this task from Needs Triage by Developer to Normal.Sep 1 2016, 4:57 PM

This is weird thing, time to poke out ogl expert @Mike Erwin (merwin) :)

Mike, do you have clues why glview and blender has such a different idea of supported ogl features? Is it core vs. compatibility contexts?

@Chip Cooper (Cyberchip), at the meantime, did you doublecheck you've got drivers installed from nvidia site? Windows 10 has a tendency of preferring it's own update thingie to install drivers and those are not always correct drivers.

System Information for above system with same issue!

Yes, downloaded directly from Nvidia Support site. Definitely not the issue as far as source goes.

opengl32	5.1.2600.5512	697.00 KB (713,728 bytes)	7/1/2016 3:00 PM	Microsoft Corporation	q:\program files\blender foundation\blender\opengl32.dll

where did that come from? that shouldn't be there

It was an attempt to fix this issue; one had suggested I place it there... I will remove that... (had forgotten). Will get back on this.

BTW, here's another piece of software claiming same issue; but, claiming it's a Windows 10 issue.
https://forum.kicad.info/t/opengl-2-1-or-higher-is-required-on-windows-10/1299

Chip Cooper (Cyberchip) closed this task as Resolved.EditedSep 1 2016, 5:15 PM

Geez, I feel like such an idiot. Right after I updated to Windows 10 Anniversary, I had this issue, and found a reference saying I needed this to fix the problem, and to put it directly into the directory. What I forgot to do was remove it, after I found out that didn't solve the problem.

Apparently, I had fixed the issue, except for the fix that didn't work! Gotta laugh... even the best of us... (sigh).

Bottom line, all is working (Thank you all!)

My apologies!

I believe I can now claim to be a Lazy Dodo... after all, like many old timers like me... I've forgotten way more than I currently know, been around that long doing this stuff.
Thanks Lazy Dodo! (sigh).

Just realized that the old ghost of .DLL Hell, and workarounds still coming around to bite me in the ass! Maybe I *am* getting too old to keep doing this stuff... :-( I can't believe I forgot to roll back after a fail.... I used to be soooo adept....

Guess I'll just be grateful... hmmm, Dodos have eagle eyes... learned something new.