Page MenuHome

boolean union produces difference
Closed, ArchivedPublic

Description

System Information
Fedora 24 x86_64
16 GB RAM
GeForce GTX 760/PCIe/SSE2 with official drivers 4.4.0 NVIDIA 358.16
Intel(R) Core(TM) i7-4771 CPU @ 3.50GHz (4 cpus, 8 cores)

Blender Version
Broken: 2.76b and 2.77a

Short description of error
Doing a boolean union on certain meshes produces wrong results.

Exact steps for others to reproduce the error
The boolean union of certain intertwined meshes give a result that looks more like a boolean difference. See the attached .blend file.

Details

Type
Bug

Event Timeline

Mathias Panzenböck (panzi) created this task.
Mathias Panzenböck (panzi) raised the priority of this task from to Needs Triage by Developer.

I believe this is the same as T47011 and T46988 and grouped into T47030?

Sergey Sharybin (sergey) closed this task as Archived.
Sergey Sharybin (sergey) claimed this task.

Current boolean implementation has has quite some bugs which are tricky to solve due to external nature of the library we're using for those operations.

We're working on a new boolean system which is going to replace current one.

Is there some kind of workaround for this issue? E.g. is there some way I could divide the mesh up, boolean merge the parts and then join the resulting meshes back together? Or do you know some external open source software I could run the mesh through that does the union operation? I need this for 3D printing where there can't be any internal geometry/overlapping meshes.

Yes. There now is in the latest build bot builds boolean in edit mode.
So first, get rid of the boolean modifier,
Then join the two loops with control J,
Then in edit mode Control F and select boolean,
then in the panel on the lower left choose union.

Oh, first A to unselect all vertices, then hover over one loop and hit L to select all linked verts, then do the Control F > boolean etc.

Thank you for that tip, but I can't see any union option:


Using the build "blender-2.77-b4b269f-linux-glibc219-x86_64.tar.bz2" from here: https://builder.blender.org/download/

Default is Difference.
But you can change the setting to Union in F6 panel.

This tool is available in 2.77a.

Ah, didn't understand that at first! Thank you! This shortens hours of manual work to seconds of clicking buttons.

Lower left panel. You may have to hit + to see it.

Hmm, it failed to remove all the faces, though. I guess that's a known beta-bug?