Page MenuHome

Render doesn't look like Camera View
Closed, ResolvedPublic

Description

System Information
S.O.: Ubuntu 14.04 64Bits
Graphic: Intel GMA HD Graphics 2000

Blender Version
version: 2.77 (sub 0), branch: master, commit date: 2016-04-05 18:12, hash: abf6f08, type: Release
Worked: (optional)

Short description of error
The render/preview (in camera view) doesn't have the proportion like 3D camera viw.

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

  1. Open Blender.
  2. Change to Render Cycles
  3. Change to camer view (Numpad 0).
  4. go to Render Properties, and change to other dimention. (example: TV NTSC 16:9)
  5. in 3D view (Press Shif + Z) and see.

Note: Test with others dimentions.

It's normal?

I'm sorry for my bad english.

Event Timeline

A. CH. (ACH2015) set Type to Bug.
A. CH. (ACH2015) added a subscriber: A. CH. (ACH2015).
A. CH. (ACH2015) created this task.
A. CH. (ACH2015) raised the priority of this task from to Needs Triage by Developer.

If you want the camera view to look like the render view, switch the viewport shading to "material".
https://www.blender.org/manual/editors/3dview/display/shading.html
3D Viewport Editor-->Header-->Viewport Shading-->Material

You can also view your world background color in your 3D viewport by enabling "world background" in:

3D Viewport Editor-->(n) properties shelf-->Display-->World background

https://www.blender.org/manual/modeling/meshes/introduction.html#Properties%20Shelf

Also, if you need help in the future, a good place to ask questions is here:
http://blender.stackexchange.com/

eroMoD (tostrong4you) closed this task as Resolved.May 27 2016, 1:52 AM
eroMoD (tostrong4you) claimed this task.
Brecht Van Lommel (brecht) reopened this task as Open.

@eroMoD (tostrong4you), please leave closing bug reports to developers.

I didn't check if there is a bug here, but this seems to be about aspect ratios, not shading.

Probalilly I do not explain me fine.
but the question it's about the proportion of the camera view that look different at the render,

Probablemente no me explique bien.
Pero, la pregunta es sobre porque el render luce diferente a la vista de la camara.

Y me disculpa si mi ingles no es muy bueno.

oh, then maybe brecht was onto it.

If you look in the Properties Editor-->Render-->Dimensions
you can choose your aspect ratio, in your examples, you have different aspect ratios set there.

A. CH. (ACH2015) added a comment.EditedMay 27 2016, 3:25 AM

I think that when change the dimention of render it's should keep the proportions of 3D view.

Creo que cuando cambia la dimensión del render este debe mantener la proporción de la vista 3D.

oh I see, are you using any nodes?

No any! the created by defualt.

It looks like the only way it works is to leave the aspect ratio at 1 : 1
But change the resolution x and y

It's the aspect ratio. The formats you selected all expect a player/device that can convert the pixel aspect ratio to the correct display aspect ratio. If you render (F12) you can see how the output looks. I made an image that hopefully explains some things:

Here you have 'DVCPRO HD 1080p' (HD = 1920x1080) but the format resolution is 1280x1080. If you need to save your animation in any format with a pixel aspect other than 1:1 but with an intended HD output resolution, do your work with the default 'HDTV 1080p' preset (viewport framing, etc.) and only change preset when you have to render.

I don't think this is a bug, since the Cycles viewport rendering always is pixel aspect 1:1 (I guess) and the camera is the intended output resolution.

I mention because in the version 2.76b don't happened.

Lo menciono por que en la versión 2.76b no me sucedió.

probably it's not a bug, but perhaps it's about the setting value of Aspect ratio.

It was indeed a bug, used to work fine. Aspect ratio should have no influence in the viewport like that, fixed now.