Page MenuHome

Blender OOM at startup
Closed, InvalidPublic

Description

System Information
Arch Linux, NVIDIA GF100 (nouveau)

Blender Version
Broken: blender -v
Blender 2.77 (sub 0)
build date: 2016-04-11
build time: 16:23:38
build commit date: 2016-04-05
build commit time: 18:12
build hash: abf6f08
build platform: GNU/Linux
build type: Release
build c flags: -Wall -Wcast-align -Werror=implicit-function-declaration -Werror=return-type -Werror=vla -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts -Wno-unknown-pragmas -Wpointer-arith -Wunused-parameter -Wwrite-strings -Wlogical-op -Wundef -Winit-self -Wnonnull -Wmissing-include-dirs -Wno-div-by-zero -Wtype-limits -Wformat-signedness -Wuninitialized -Wredundant-decls -Wshadow -Wno-error=unused-but-set-variable -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fuse-ld=gold -fopenmp -std=gnu99 -msse2 -msse -pipe -fPIC -funsigned-char -fno-strict-aliasing
build c++ flags: -Wredundant-decls -Wall -Wno-invalid-offsetof -Wno-sign-compare -Wlogical-op -Winit-self -Wmissing-include-dirs -Wno-div-by-zero -Wtype-limits -Werror=return-type -Werror=implicit-function-declaration -Wno-char-subscripts -Wno-unknown-pragmas -Wpointer-arith -Wunused-parameter -Wwrite-strings -Wundef -Wformat-signedness -Wuninitialized -Wundef -Wmissing-declarations -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fuse-ld=gold -fopenmp -msse2 -msse -pipe -fPIC -funsigned-char -fno-strict-aliasing
build link flags: -Wl,--version-script='/build/blender/src/blender-2.77.a/source/creator/blender.map'
build system: CMake

Worked:

Blender 2.76 (sub 0)
build date: 2016-02-16
build time: 21:05:22
build commit date: 2015-11-03
build commit time: 10:56
build hash: f337fea
build platform: Linux
build type: Release
build c flags: -Wall -Wcast-align -Werror=declaration-after-statement -Werror=implicit-function-declaration -Werror=return-type -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts -Wno-unknown-pragmas -Wpointer-arith -Wunused-parameter -Wwrite-strings -Wlogical-op -Wundef -Winit-self -Wnonnull -Wmissing-include-dirs -Wno-div-by-zero -Wtype-limits -Wformat-signedness -Wuninitialized -Wredundant-decls -Wno-error=unused-but-set-variable -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -std=gnu89 -fuse-ld=gold -fopenmp -msse2 -msse -pipe -fPIC -funsigned-char -fno-strict-aliasing
build c++ flags: -Wredundant-decls -Wall -Wno-invalid-offsetof -Wno-sign-compare -Wlogical-op -Winit-self -Wmissing-include-dirs -Wno-div-by-zero -Wtype-limits -Werror=return-type -Werror=declaration-after-statement -Werror=implicit-function-declaration -Wno-char-subscripts -Wno-unknown-pragmas -Wpointer-arith -Wunused-parameter -Wwrite-strings -Wundef -Wformat-signedness -Wuninitialized -Wundef -Wmissing-declarations -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fuse-ld=gold -fopenmp -msse2 -msse -pipe -fPIC -funsigned-char -fno-strict-aliasing
build link flags: -Wl,--version-script='/build/blender/src/blender-2.76.b/source/creator/blender.map'
build system: CMake
Short description of error

Exact steps for others to reproduce the error
Start the program, computer lockup, then crash. (OOM on 6GB of ram)
Regression.

Details

Type
Bug

Event Timeline

John Doe (tonemgub) set Type to Bug.
John Doe (tonemgub) created this task.
John Doe (tonemgub) raised the priority of this task from to Needs Triage by Developer.
Campbell Barton (campbellbarton) triaged this task as Needs Information from User priority.

I'm using a similar setup currently.

Arch Linux, NVIDIA GF106 (nouveau).

And its working well.

From the debug output, there are a few GL Error's, I'm not seeing any here.
This hints that OpenGL libraries/driver are the issue, since Blender shouldn't be giving GL-errors on startup.

Could you test:

  • Run Blender with software GL, eg: LIBGL_ALWAYS_SOFTWARE=1 ./blender --debug-all
  • If your able, see if this is caused by switching to the nvidia drivers (I use this script).
  • Disable the OOM-Killer.
John Doe (tonemgub) closed this task as Invalid.May 30 2016, 4:03 PM
John Doe (tonemgub) claimed this task.

I'm unsure what the actual issue was, but re-installing blender has fixed this issue. Also tested the latest build from blender.org and it worked fine. Closing invalid.

Thanks!