Page MenuHome

Blender cannot interpret Right Click for Wacom Tablet
Closed, ResolvedPublic

Description

System Information

Graphics:
ATI Radeon 5770 (x2)

System Software Overview:

System Version:	OS X 10.11.5 (15F34)
Kernel Version:	Darwin 15.5.0
Boot Volume:	Macintosh HD
Boot Mode:	Normal
Secure Virtual Memory:	Enabled
System Integrity Protection:	Enabled
Model Name:	Mac Pro
Model Identifier:	MacPro5,1
Processor Name:	Quad-Core Intel Xeon
Processor Speed:	2.4 GHz
Number of Processors:	2
Total Number of Cores:	8
L2 Cache (per Core):	256 KB
L3 Cache (per Processor):	12 MB
Memory:	14 GB
Processor Interconnect Speed:	5.86 GT/s
Boot ROM Version:	MP51.007F.B03
SMC Version (system):	1.39f11
SMC Version (processor tray):	1.39f11

Wacom Driver info:
Intros PT S CTH-480
Version 1.00
Driver version: 6.3.16-12

Blender Version
Broken: 2.77a abf6f08

Short description of error

Blender interprets "right click" as "left click," only for my Wacom pen and tablet. I've assigned all buttons to be "Right Click" on my pen and it still does not work properly.

Tried reinstalling Wacom drivers, resetting and redownloading Blender, restarting system, plugging into different USB ports... no success.

Exact steps for others to reproduce the error

Does not work for any .blend files

USB Device info:
Intuos PTS:

Product ID:	0x0302
Vendor ID:	0x056a  (WACOM Co., Ltd.)
Version:	1.00
Speed:	Up to 12 Mb/sec
Manufacturer:	Wacom Co.,Ltd.
Location ID:	0xfa230000 / 4
Current Available (mA):	1000
Current Required (mA):	498
Extra Operating Current (mA):	0

Details

Type
Bug

Event Timeline

jen (jenerator) added a project: BF Blender.
jen (jenerator) set Type to Bug.
jen (jenerator) added a subscriber: jen (jenerator).
jen (jenerator) created this task.
jen (jenerator) raised the priority of this task from to Needs Triage by Developer.

I can verify this error. Mapping anything on the tablet as right-click (e.g. the accessory buttons) acts as a left-click.

I suspect OS X Blender's method for polling the input is lower level than the OS would suggest (since the Wacom drivers are able to send the events correctly to other applications).

Hi folks
Until i abandoned OSX last years may, i always used to work in blender exclusively
with a wacom graphire4. I never experienced such problem, had used both pen buttons
always. ( but not flipped )
So this may be a new issue ?

Jens

It's a bug in SDL2.

Here's GZDoom made with SDL and it also misdetects a right click from a Wacom device as a left click.

Sure, I'm familiar with this code & have some Wacom gear at home.

We don't use SDL to get tablet events, but maybe we have the same bug!

Works correct for me on OS X 10.11 with a Wacom Bamboo, I can't reproduce the problem here. We don't use SDL for getting tablet events, so that's not the issue.

I've committed a possible fix for this issue, but can't test it myself. Please try tomorrow's build from https://builder.blender.org/download/ to see if the issue is fixed.

Brecht Van Lommel (brecht) triaged this task as Normal priority.Jun 11 2016, 8:52 PM
jen (jenerator) closed this task as Resolved.Jun 13 2016, 6:12 PM

Incredible. Checked out 2.77 cefbe8f and my Wacom tablet is now registering right clicks. Thanks a ton.

Thanks, I came here with the same problem, and the daily build solved it for me. Mac/Intuos

Nightly build solved it for me as well with a Cintiq 27 QHD. Thanks!

Works correct for me on OS X 10.11 with a Wacom Bamboo, I can't reproduce the problem here. We don't use SDL for getting tablet events, so that's not the issue.
I've committed a possible fix for this issue, but can't test it myself. Please try tomorrow's build from https://builder.blender.org/download/ to see if the issue is fixed.

You fixed it! If you could share with us how you did it, that would be great because even if you're not using SDL, I was able to confirm SDL (1&2) demonstrate the same problem.

The fix was in rB0b415700f450: Attempted fix for T48625: tablet button configured to right click not working…. It's basically giving [event type] priority over [event buttonNumber] to determine if it's the left, right or another button.