Page MenuHome

Black holes in Glossy Reflections
Closed, ArchivedPublic

Description

System Information
Operating system and graphics card
Debian 8 64bit, GTX 780

Blender Version
Broken: (example: 2.77a abf6f08, see splash screen)
Worked: (optional)

Short description of error

There are black holes in reflections on the objects on some angles.
Take a look some screenshots.


Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Create simple scene with a cube, set smooth shading (IMPORTANT, this bug won't work on flat shading), add simple glossy material with roughness 0 (it will be easier to see these holes with low roughness), add HDR to environment. Go to render mode and watch at the surface. You will see black holes on surface. I think that it is the issue of normals interpolation, because you can add few levels of edge bevel.

But what if I don't want to add additional polygons with subdivide or bevel? Bug!

Details

Type
Bug

Event Timeline

Ivan Lebedev (ITdreamer) set Type to Bug.
Ivan Lebedev (ITdreamer) created this task.
Ivan Lebedev (ITdreamer) raised the priority of this task from to Needs Triage by Developer.

Here is simple SCENE

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

This is not considered a bug, if the smooth normals of the mesh are very different than the actual mesh geometry we can't compute a correct reflection. Most renderers suffer from this issue in one way or another. We might find ways to improve this in the future, but for now it's a known limitation.