Page MenuHome

RGB Curves node having an effect on components that they shouldn't.
Closed, ArchivedPublic

Description

System Information
Ubuntu 14.04 and graphics card Intel HD 4600 Graphics

Blender Version
Broken: (example: 2.77a abf6f08

Short description of error
The bug deals with the RGB Curves suppressing the lens flare AFTER the Alpha Over node.
The concept in the node tree is to color correct the ship object which is off screen at this time. Based on the RGB Curves location in the node tree the expectation is that the color correction would be limited to the ship object. However if you un-mute the RGB Curves node You will see that it also gets applied to the image coming in from the Add node. I have observed this behaviour also in the Brightness/Contrast node. That however does not seem to show up in this composite tree if I put the Brightness/Contrast node in the tree in place of the RGB Curves.

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Blend File:

Details

Type
Bug

Event Timeline

George Muhs (oldskoolvfx) set Type to Bug.
George Muhs (oldskoolvfx) created this task.
George Muhs (oldskoolvfx) raised the priority of this task from to Needs Triage by Developer.
Sergey Sharybin (sergey) closed this task as Archived.
Sergey Sharybin (sergey) claimed this task.

With this particular file the difference is caused by RGB curves pushing colors to negative region. After alpha-overing negative colors on top of something some areas might become darker, or even bigger artifacts might appear because of alpha-over result also going negative colors.

So far i don't really see failure of Blender here.

If you've got issues with cases when there are no negative colors involved, please upload new .blend file with all included data needed to reproduce that exact issue.