Page MenuHome

NEW-DEPSGRAPH - Dupligroup from dupligroup strange behaviour.
Closed, ResolvedPublic

Description

Ubuntu-Mate 14.04 64x, nVidia GT-620
Blender 2.77a from page

This issue was discovered in a file downloaded from http://www.blendswap.com/blends/view/63269. I tried to reproduce it with simple objects, but it didn't work. I only cleaned up a bit the file to be more understandable.

This pine consists in:

  • A branch
    • Mesh: Needles.Base.master
    • In Groups: Needles.Base and Needles.FullBase and Pinetree
    • Layer 20
  • dupli-branches:
    • Dupligroup of Needles.Base
    • In groups Needles.FullBase and Pinetree
    • Layer 20
  • dupli-dupli-branches:
    • Dupligroup of Needles.FullBase
    • In groups Pinetree
    • Layer 20
  • Tree
    • Dupligroup of Pinetree
    • Layer 1

The branch ("mesh") can be moved, also the first dupli ("1º dupli"). But branches-dupli-dupli ("2º dupli") can't.

Also, the tree (layer 1) can be moved.

Details

Type
Bug

Event Timeline

Mario Mey (mariomey) raised the priority of this task from to Needs Triage by Developer.
Mario Mey (mariomey) updated the task description. (Show Details)
Mario Mey (mariomey) set Type to Bug.
Mario Mey (mariomey) added a comment.EditedJul 6 2016, 10:18 PM

I correct myself: it does move... but it is not visible until release the movement and move it again. In that moment, the object's new place is visible.

Sergey Sharybin (sergey) lowered the priority of this task from Needs Triage by Developer to Normal.

Didn't check in details yet, but new depsgraph issues goes to me!

Sergey Sharybin (sergey) closed this task as Resolved.Jul 13 2016, 2:03 PM

Similar issue was reported by artists here in the studio, so apparently it was fixed in rB527674b.

Thanks for the report!