Page MenuHome

Collada export "use_blender_profile" not used or set when exporting armature
Closed, InvalidPublic

Description

Blender Version
2.77a

Short description of error

"connect", "roll", "tip_x", "tip_y", "tip_z", not generated when exporting in Collada format (whatever the exported armature is).

In ArmatureExporter.cpp/$177, the code for exporting these values is here. But where to set or activate the "use_blender_profile" option ?

Details

Type
Bug

Event Timeline

Sergey Sharybin (sergey) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Jul 7 2016, 3:46 PM

Please always provide steps to reproduce the issue including all files needed for that.

Hi,

Simply export in Collada format the object of the blend file.

The question from stack exchange is here with a link to the file : BSE link

Or directly here in Blend Exchange : Blend Exchange link

I don't know what to add more : a simple cube, a 2-bones armature and export in Collada format.
"connect", "roll", "tip_x", "tip_y", "tip_z" are absent from the file.

This appears to apply to any attempt to export to collada.

If we look in collada.h we can see that collada_export() takes 19 arguments, the first 2 being scene and filepath. The remaining 17 arguments can be found within uiCollada_exportSettings() located in io_collada.c which would appear to be the code that displays the export options panel in the file browser.

Of those 17 properties 16 are visible in the export option panel use_blender_profile being the missing one. I don't see any code that would conditionally hide that property. The property can even be found in rna_scene_api.c along with the other options.

Within ArmatureExporter::add_bone_node() located in ArmatureExporter.cpp at line 177 that missing property adjusts the export data in a way that adds data that @Lemon Acidjuice (lemonacidjuice) wants included in the export.

So the option exists, the code is there to use it but we can't turn it on/off and don't see why.

One hint may be the fact that in the python console, auto-complete does not show this property in the help text for bpy.ops.wm.collada_export() so it may be an error that prevents the property being visible to python.

Did you guys tried latest build from our buildbot? Afaics Use Blender Profile is there… @Gaia Clary (gaiaclary) shall know better too.

Gaia Clary (gaiaclary) closed this task as Invalid.Jul 23 2016, 12:33 PM
Gaia Clary (gaiaclary) claimed this task.

I answered at stack exchange.
You only need to download a recent daily build.
Closing as invalid (since nothing needed to be fixed)