Page MenuHome

Displace modifier ignores 'Simple' subdivision if scale is unapplied
Closed, InvalidPublic

Description

System Information
Windows 10 64-bit, Nvidia gtx 570 (render), Nvidia gt 610 (display)

Blender Version
Broken: 2.77a, a92fc34
Worked: -

Short description of error

The displace modifier ignores the Subsurf modifier if the Subsurf's subdivision type is set to 'Simple' and the scale on the object is unapplied. I understand applying scale is often important for modifiers to work correctly, but what threw me off was the fact that normal 'Catmull-Clark' subdivision works fine but 'Simple' shows no effect at all.

Exact steps for others to reproduce the error

  1. Open
  2. Switch the 'Subsurf' modifier's subdivision type from 'Simple' (no effect) to 'Catmull-Clark' to see the effects of the Displace modifier.

Details

Type
Bug

Event Timeline

I think this is not a bug, just the cloud procedural giving those zero values at those local coords...
Will double check in a bit...

Yep, looks like clouds procderural at scale 1 will give output values of .5 at corners [0,0], [0,1], [1,1], [1,0]
--> So no displacement there
file from report uses clouds at scale .25 which will give no displacement at all vertices even at subd level 2 or 3.

havent looked at the actual code but some other things to try:

  • try subdividing further and displacement will show up
  • try translating vertices in editmode and displacement will show up
  • try using global coords in displace modifier and displacement will show up
  • try any other procedural [voronoi or something] and displacement will show up
  • try altering the colors of the cloud procedural with a ramp and displacement will show up
Bastien Montagne (mont29) closed this task as Invalid.
Bastien Montagne (mont29) claimed this task.

Can totally confirm @Philipp Oeser (lichtwerk) diagnostic here… No bug at all, just odd effect of procedural textures!