Page MenuHome

Switching between Dope Sheet 'modes' causes 'Show Sliders' to renable itself
Closed, InvalidPublic

Description

System Information
Windows 10 64-bit, Nvidia gtx 570 (render), Nvidia gt 610 (display)

Blender Version
Broken: (example: 2.69.7 4b206af, see splash screen)
Worked: (optional)

Short description of error

Switching between the 'Dope Sheet' mode of the Dope Sheet Editor and the 'Shape Key Editor' mode causes the 'Show Sliders' property to keep re-enabling itself.

Exact steps for others to reproduce the error

  1. Open . 'Show Sliders' is disabled in the Dope Sheet Editor.
  2. Switch to 'Shape Key Editor' mode. 'Show Sliders' is enabled.
  3. Switch back to 'Dope Sheet' mode and sliders are now enabled.
  4. Disabling 'Show Sliders' and switching modes again just re-enables it.

Details

Type
Bug

Event Timeline

Joshua Leung (aligorith) closed this task as Invalid.Jul 9 2016, 1:35 AM
Joshua Leung (aligorith) claimed this task.

Not a bug.

It is intentionally activated for the shapekey editor, as that the ShapeKey Editor is pretty much useless without them being shown.

Unfortunately, this setting is shared between the modes, so it tends to hang around in the dopesheet when switching back. We can look into whether they should be using separate settings instead though...