Page MenuHome

Shape keys only use the initial state of a vertex group, and are unaffected by vertex weight modifiers
Closed, InvalidPublic

Description

Version: 2.77 (linux 64bit)

How to reproduce:

  1. Open attached file and inspect the grid object's modifers, weights and shape keys
  2. Note how the vertex weight modifier has no effect on the resulting shape, when it should
  3. Note how no feature that dynamically affects the vertex weight (dynamic paint or vertex weight modifiers) has an effect on the resulting mesh shape key

Expected behavior:

Procedural changes to a vertex group should affect the shape keys influenced by that group. Not being able to dynamically effect the vertex weight of a shape key is a pretty serious limitation. One can imagine a lot of uses which are currently closed to the user.

Details

Type
Bug

Event Timeline

Campbell Barton (campbellbarton) closed this task as Invalid.

Shape keys are applied before other modifiers.
This is working as intended, closing.