Page MenuHome

Boolean operations, parenting, interface and documentation issues.
Closed, ArchivedPublic

Description

System Information
Windows 10 AMD Mobility Radeon HD 5000 Series (Hybrid Intel)

Blender Version
Broken: 2.77a abf6f08

Short description of error
Sensible desired parenting conflicts unexpectedly with boolean operations and terminology used for boolean operands in interface is confusing and manual is wrong.

Exact steps for others to reproduce the error
Start with simple cube. Create a cylinder of radius 0.25
Select cube. Apply modifier, Boolean. Set type to difference. Set 'target' to cube. The 'target' is subtracted from the cube.

  1. Select cylinder and set parent to cube. Console window shows:

Dependency cycle detected:

Cylinder depends on Cube through Parent.
Cube depends on Cylinder through Boolean Modifier

However, you really want to be able to do this, so that when you move the modified cube, the cylinder keeps it's relative position, preserving the boolean op.

  1. 'Target' is poor terminology, especially for difference, as the object the op is applied to is conceptually the target, not vice-versa. 'Tool object', 'Applied object', 'operand' or similar might be better terminology. The 'target' in all types of operation is unaffected by the operation; targets conceptually are affected.
  1. This confusion extends to the manual. It (https://www.blender.org/manual/modeling/modifiers/generate/booleans.html) says:

Difference

The modified mesh is subtracted from the target mesh.

Which is the opposite of what actually happens. Intersection is also very poorly described.

Details

Type
Bug

Event Timeline

Sergey Sharybin (sergey) closed this task as Archived.Aug 3 2016, 11:36 AM
Sergey Sharybin (sergey) claimed this task.

This is no longer an issue with new dependency graph, which we'll make default one int the 2.8 branch. This issue will not be fixed in the current default dependency graph because it is not capable of supporting such cases.

The term "Target" follows others areas in Blender and before we accept/reject such changes they are to be discussed with the usability team.

So thanks for the report, but there is no currently bug in Blender here.