Hair particle system and OpenCL issue on AMD 7870 (possible driver related)
Closed, InvalidPublic

Description

Tested with latest build 5.8.2016.
Driver: Crimson 16.7.3

Hair PS is connected with OpenCl issue on AMD 7870. (GCN1, Pitcairn).
Reproducing steps:

  1. Cube with hair PS is on scene (not in camera view)

  1. Render result:

  1. Cube with hair PS is on scene (not in camera view) with restrict rendering

  1. Render result (renders fine):

Conclusion: If object with hair PS is on scene, there are some shading issues.

Details

Type
Bug
Sergey Sharybin (sergey) triaged this task as "Incomplete" priority.Aug 5 2016, 12:50 PM

Tested on W8000 (which is also GCN 1.0) on Windows 10 and freshly re-installed 16.7.3 driver and can't reproduce the issue.

Questions:

  • Does the issue happen with previous Blender releases (2.76, 2.77a) ?
  • Does the issue happen with previous driver versions?
  • Does the issue depend on tile size?
Tom (vejn) added a comment.EditedAug 5 2016, 1:14 PM
  • Does the issue happen with previous driver versions?

Yes

  • Does the issue depend on tile size?

No. I tried with lower tile size and the same happens.

  • Does the issue happen with previous Blender releases (2.76, 2.77a) ?

This is render result with 2.76, 2.77a with the same file. It seams that light is not computed right. Render is not the same as with 2.77.3

Sergey Sharybin (sergey) raised the priority of this task from "Incomplete" to "Normal".Aug 9 2016, 12:20 PM

Thanks for the tests, but i still can't reproduce the issue. And for bugs like this it is crucial to be able to reproduce it in order to fix..

@Brecht Van Lommel (brecht), maybe you can reproduce the bug?

No, I couldn't reproduce this bug, tested with an R9 380 on Windows.

Thanks. Than it's probably driver issue with AMD 7870.

Occurs on AMD HD7770 (GCN 1.0) on Windows 10 64bit and AMD Crimson drivers 16.8.1, using Blender 2.77a but only when hair is enabled and when the experimental GPU Rendering feature set is also enabled.

Here is a simple scene I can share where the problem easily shows.

I have reported this to AMD's driver team aswell.

If helpful i could provide a Teamviewer Access to a GCN 1.0 System.

OpenCL error (-61): CL_INVALID_BUFFER_SIZE in clCreateBuffer  
OpenCL error: CL_INVALID_MEM_OBJECT in clEnqueueWriteBuffer(cqCommandQueue, CL_MEM_PTR(mem.device_pointer), CL_TRUE, 0, size, (void*)mem.data_pointer, 0, NULL, NULL)

Today it took about 4 minutes to cancel the render.
With 2.76b, Cycles cancels render almost immediately. Scene had about 100 000 faces.

I think it has something to do how driver operates the GPU memory.
Flushing the memory takes ages.

This comment was removed by Tom (vejn).
Tom (vejn) added a comment.EditedAug 16 2016, 6:37 PM

Today's build didn't crash but hair rendering is still fault. I post console log if it helps.
Is it possible to implement test variables for console log to detect this issue's source ?

Tom (vejn) added a comment.EditedSep 6 2016, 7:23 PM

There is issue with Interpolated mode. In the process of rendering, Blender freezes with Interpolated mode. I captured the screen when it froze.

That's weird, we did not do any explicit fixes for the hair. Could be the commit which changed the internal data layout tho.

For the freezing, did you try setting tiles to some really low value (like 64x64) and rendering few samples (like, 1 sample, if that works 10 samples..) ?

Tom (vejn) added a comment.EditedSep 7 2016, 11:23 AM

That's weird, we did not do any explicit fixes for the hair. Could be the commit which changed the internal data layout tho.

Whatever you changed in this release, please keep it.

For example, first 2.78 RC1 build rendered this (Crimson 16.8.2 hotfix 2):

As subdivision level of the mesh goes up, there are more tesselation artifacts if the hair is present on the scene.

Fiji and Polaris cards didn't have this issue, only 7xxx series. Could it be connected with GPU memory and internal data layout which you said you changed?
Or maybe is on behalf of AMD's 16.8.3 drivers.

For the freezing, did you try setting tiles to some really low value (like 64x64) and rendering few samples (like, 1 sample, if that works 10 samples..) ?

Thank you. I'll try.

Tom (vejn) added a comment.EditedSep 10 2016, 3:06 AM

@Sergey Sharybin (sergey) I did't set up the GPU compute properly.
The issue is still there in the build 9.9.2016 with 16.8.3.

I tried various tiled sizes:
default, 64×60, 512×512 and the same weird shading is present.

I have the same problem with HD7950.
Driver: Crimson 15.12 (сan test with latest version if needed)

blender-2.78-rc2-windows64
GPU:

CPU:

Blender 2.77a (2016-04-05) hash: abf6f08
GPU:

CPU:
identical to GPU

Tom (vejn) added a comment.EditedSep 18 2016, 6:45 PM

@John (Jns_76) please test newest drivers
http://support.amd.com/en-us/download/desktop?os=Windows+10+-+64
16.9.1

Also, report to AMD http://www.amd.com/report because apparently Fiji and Polaris cards are not affected with this.
AMD is reworking issues from the latest versions of drivers so it's better to give feedback.

Please, test this file https://developer.blender.org/T49371
I think this 2 issues could have some connections because if you have more subdivision levels (standard or new adaptive microdisplacement), there are more tesselation artifacts/render result is darken.

@John (Jns_76) please test newest drivers

Installed. Now everything is broken. Great.
whql-win7-64bit-radeon-software-crimson-16.9.1-sep13

blender-2.78-rc2-windows64
sun strength-50

Blender 2.77a (2016-04-05) hash: abf6f08
sun strength-50

Blender both versions
sun strength-1

I don't even sure how to report this...

Testing

with Catalyst 16.9.1
CPU render

//////
GPU render with blender-2.78-78c380d-win64 build (you can see weird shading on sphere and in viewport comparing to CPU render)

/////
With @john peterson (bliblubli) build https://uploadfiles.io/90e0707ou
you can see strange tesselation shading on sphere is gone. But render is too dark still.

///////
Could you implement bliblubli's OpenCl code? It solves tesselation shading when hair PS in on scene.

Tom (vejn) added a comment.EditedOct 13 2016, 8:58 PM

Still black screen and hair PS issue with blender-2.78-3e460b6-win64.zip and Crimson 10.1 on AMD 7870.

Aaron Carlisle (Blendify) lowered the priority of this task from "Normal" to "Incomplete".Apr 17 2017, 7:07 PM

Please try again with latest build from builder.blender.org/download

Fable Fox (fablefox) closed this task as "Invalid".EditedThu, May 4, 8:41 AM
Fable Fox (fablefox) claimed this task.
  1. No news in over a week... closing
  2. Last version tested was in Oct 2016.