Page MenuHome

Node wrangler bug
Closed, ArchivedPublic

Description

Windows 8.0
nvidia GTX950

Blender 2.77a
Broken: (example: 2.69.7 4b206af, see splash screen)
Worked: (optional)

When I make a frame for nodes (shift+P) and after the f6 key for options to change the color that appears in the error - generated frame with this color!

Details

Type
Bug

Event Timeline

Thanks for the report, but I can't seem to reproduce this issue. Can you try again with the latest version? Get it here: https://git.blender.org/gitweb/gitweb.cgi/blender-addons.git/blob_plain/HEAD:/node_wrangler.py

Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Normal.Aug 11 2016, 12:18 PM

Hello Greg! today find the file where error appears! also attach a screengrab, made at the time of occurrence of an error! And send the file! Version plugin 3.29 (thanks for the new version, by the way!)

Greg Zaal (gregzaal) triaged this task as Confirmed, Medium priority.

I see - this only breaks if you're in edit mode - in object mode it works fine.

This seems to be a bug with Blender's redo system I think. How it's supposed to work is that when you hit F6 and change one of the operator properties, it performs an undo and then redo with the new settings. Only in this case, it does not actually undo at all, so each time you change the color it repeats the operator.

It's not only this Frame function either, it's broken for all node operators (even the built-in ones) - e.g. if you duplicate the node, place it somewhere, and then press F6 and change the location vector there, it creates multiple copies (only if you're in edit mode. In object mode it works as expected).

@Bastien Montagne (mont29) not sure who to assign for this, but it's a bug with blender in general, not the add-on.

Bastien Montagne (mont29) closed this task as Archived.Aug 13 2016, 6:37 PM
Bastien Montagne (mont29) claimed this task.

Uuuuuh… OK, that’s one of those undo system issue… Then I suppose this is more like known limitation/TODO for now, fixing this is far from trivial and will likely require some serious changes to our undo system :|

Thanks for the report anyway.

glad I was able to find the error, whatever it was, plugin, or the program itself, anyway-this is another step towards stability!