Page MenuHome

Blender crashes hard with new nvidia drivers
Closed, ArchivedPublic

Description

System Information
GENTOO Linux (daily updated) Linux kernel 4.7.1 / 4.7.0 (tested both)
x11-drivers/nvidia-drivers-370.23

Blender Version
Broken: blender-2.77-2016-08-19-4d8ac1e-linux-glibc219-x86_64.tar.bz
also blender-2.77-2016-08-17-294eac2-linux-glibc219-x86_64.tar.bz2
Worked: with x11-drivers/nvidia-drivers-367.35-r1

Short description of error
As soon F12 is hit, Blender crashes. "Works" with any scene.
Crashdump:

Blender 2.77 (sub 3), Commit date: 2016-08-18 23:20, Hash 4d8ac1e

bpy.ops.mesh.primitive_cube_add(radius=1, view_align=False, enter_editmode=False, location=(0, 0, 0), layers=(True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False)) # Operator
bpy.ops.object.camera_add(view_align=True, enter_editmode=False, location=(0, 0, 0), rotation=(1.5708, -0, -0), layers=(True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False)) # Operator
bpy.ops.transform.translate(value=(5.04661e-16, -4.83379, 2.27279), constraint_axis=(False, False, False), constraint_orientation='NORMAL', mirror=False, proportional='DISABLED', proportional_edit_falloff='SMOOTH', proportional_size=1) # Operator
bpy.ops.transform.rotate(value=0.615146, axis=(-1, -2.22045e-16, -4.93038e-32), constraint_axis=(False, False, False), constraint_orientation='NORMAL', mirror=False, proportional='DISABLED', proportional_edit_falloff='SMOOTH', proportional_size=1) # Operator
bpy.ops.object.lamp_add(type='POINT', radius=1, view_align=False, location=(0, 0, 0), layers=(True, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False, False)) # Operator
bpy.ops.transform.translate(value=(0, 0, 2.94804), constraint_axis=(False, False, True), constraint_orientation='GLOBAL', mirror=False, proportional='DISABLED', proportional_edit_falloff='SMOOTH', proportional_size=1) # Operator
bpy.ops.view3d.object_as_camera() # Operator

backtrace

/home/user/data/pools/pool05/blender/blender(BLI_system_backtrace+0x1d) [0x198470d]
/home/user/data/pools/pool05/blender/blender() [0x1030b59]
/lib64/libc.so.6(+0x33770) [0x7efc77c2c770]
/lib64/libpthread.so.0(pthread_mutex_lock+0x4) [0x7efc79225da4]
/usr/lib64/libnvidia-opencl.so.1(+0x1d9d98) [0x7efc4c7aed98]
/usr/lib64/libnvidia-opencl.so.1(+0x28fc41) [0x7efc4c864c41]
/usr/lib64/libnvidia-opencl.so.1(+0x28fdb5) [0x7efc4c864db5]
/usr/lib64/libnvidia-opencl.so.1(+0x1dfad4) [0x7efc4c7b4ad4]
/usr/lib64/libnvidia-opencl.so.1(+0x1e1327) [0x7efc4c7b6327]
/usr/lib64/libnvidia-opencl.so.1(+0x1b54f6) [0x7efc4c78a4f6]
/usr/lib64/libnvidia-opencl.so.1(+0xb4d7d) [0x7efc4c689d7d]
/usr/lib64/libnvidia-opencl.so.1(+0xb4d18) [0x7efc4c689d18]
/usr/lib64/libOpenCL.so(+0x21f2) [0x7efc4fe2a1f2]
/usr/lib64/libOpenCL.so(+0x3e82) [0x7efc4fe2be82]
/usr/lib64/libOpenCL.so(clGetPlatformIDs+0x11) [0x7efc4fe2a6c1]
/home/user/data/pools/pool05/blender/blender() [0x1fb0f3d]
/home/user/data/pools/pool05/blender/blender(_ZN3ccl18device_opencl_infoERNS_6vectorINS_10DeviceInfoENS_16GuardedAllocatorIS1_EEEE+0x44) [0x1fb4174]
/home/user/data/pools/pool05/blender/blender(_ZN3ccl6Device17available_devicesEv+0x180) [0x1f92370]
/home/user/data/pools/pool05/blender/blender(_ZN3ccl11BlenderSync18get_session_paramsERN2BL12RenderEngineERNS1_15UserPreferencesERNS1_5SceneEb+0x157) [0x1ea1167]
/home/user/data/pools/pool05/blender/blender(_ZN3ccl14BlenderSession14create_sessionEv+0x42) [0x1e97f82]
/home/user/data/pools/pool05/blender/blender(_ZN3ccl14BlenderSession6createEv+0x9) [0x1e99309]
/home/user/data/pools/pool05/blender/blender() [0x1e90174]
/home/user/data/pools/pool05/blender/blender(PyCFunction_Call+0xb9) [0x296d6c9]
/home/user/data/pools/pool05/blender/blender(PyEval_EvalFrameEx+0x8766) [0x29e6a76]
/home/user/data/pools/pool05/blender/blender() [0x29e7b4e]
/home/user/data/pools/pool05/blender/blender(PyEval_EvalFrameEx+0x6d13) [0x29e5023]
/home/user/data/pools/pool05/blender/blender() [0x29e7b4e]
/home/user/data/pools/pool05/blender/blender(PyEval_EvalCodeEx+0x23) [0x29e7c23]
/home/user/data/pools/pool05/blender/blender() [0x2949cc4]
/home/user/data/pools/pool05/blender/blender(PyObject_Call+0x5c) [0x291f4ec]
/home/user/data/pools/pool05/blender/blender() [0x1415bbe]
/home/user/data/pools/pool05/blender/blender() [0x18c2157]
/home/user/data/pools/pool05/blender/blender(RE_engine_render+0x313) [0x13964d3]
/home/user/data/pools/pool05/blender/blender() [0x13a8cb9]
/home/user/data/pools/pool05/blender/blender() [0x13a92f8]
/home/user/data/pools/pool05/blender/blender() [0x13ac007]
/home/user/data/pools/pool05/blender/blender(RE_BlenderFrame+0xfd) [0x13acbbd]
/home/user/data/pools/pool05/blender/blender() [0x12efe81]
/home/user/data/pools/pool05/blender/blender() [0x104058a]
/lib64/libpthread.so.0(+0x75e6) [0x7efc792235e6]
/lib64/libc.so.6(clone+0x6d) [0x7efc77ce49ad]

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps
Crash can bi triggered by any scene.
Install Kernel 4.7.0/4.7.1
Install above mentioned nvidia-drivers (previous version will NOT compile with that kernel!)
Start blender.
Render.
KABOOM!
Why urged to update kernel:
http://www.heise.de/security/meldung/Sicherheitsforscher-kapern-HTTP-Verbindungen-von-Linux-3292257.html
Fixed with Kernel >= Linux 4.7.0

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) triaged this task as Needs Information from User priority.

It's crashing in the NVidia driver when querying the available OpenCL devices.

Does running clinfo in the terminal crash as well? If not, can you attach its output?

Hi Brecht,

Hmmmm...not really knowing what you want me to do, but happy if I can be of help....;)

computer:/home/user>clinfo
zsh: command not found: clinfo
[1] 5112 exit 127 clinfo

In the Python console of blender:
PYTHON INTERACTIVE CONSOLE 3.5.1 (default, Apr 12 2016, 13:42:55) [GCC 5.3.1 20160121]

Command History: Up/Down Arrow
Cursor: Left/Right Home/End
Remove: Backspace/Delete
Execute: Enter
Autocomplete: Ctrl-Space
Zoom: Ctrl +/-, Ctrl-Wheel
Builtin Modules: bpy, bpy.data, bpy.ops, bpy.props, bpy.types, bpy.context, bpy.utils, bgl, blf, mathutils
Convenience Imports: from mathutils import *; from math import *
Convenience Variables: C = bpy.context, D = bpy.data

clinfo

Traceback (most recent call last):

File "<blender_console>", line 1, in <module>

NameError: name 'clinfo' is not defined

Both seem not to be regnized as command...
Dont hesitate to ask for more! I am happy if I could be of help!

Best
mcc

clinfo is a command line utility similar to glxinfo. It's available as a package in most Linux distributions, but it seems not in Gentoo.

Basically what I would like you to test is if your OpenCL installation is somehow broken and crashing everywhere, or if there's a Blender specific issue. You could try running LuxMark instead of clinfo.

You could also try uninstalling everything OpenCL and NVidia related and reinstalling, in case that somehow fixes things.

YAFU (YAFU) added a subscriber: YAFU (YAFU).EditedAug 19 2016, 8:45 PM

I can confirm this. Kubuntu 16.04 - GTX 960 - nvidia 370.23 (beta driver acording nvidia home site). Blender from buildbot: d41dfe3

To reproduce:
Open Blender > choose 'Cycles Render' >> Blender crash



By the way, luxmark 3.1 is working well

Brecht Van Lommel (brecht) raised the priority of this task from Needs Information from User to Confirmed, Medium.Aug 19 2016, 9:45 PM

I can confirm the crash with this 370.23 driver version on Linux.

It seems to be crashing when using clew, while working fine when linking directly against the OpenCL library.

Actually, the problem is not with clew, but with initializing both CUDA and OpenCL. The order doesn't matter, it either crashes in clGetPlatformIDs() or cuInit().

I'll report a bug with repro to NVidia, hopefully they can solve it for the final driver version.

. Their bug tracker is down until sunday though.

Hi Brecht, hi YAFU,

can I do anything helpful more here for this case or do we have simply to waot for NVidia to fix
the problem?

No, we just wait for NVidia now.

The NVidia bug I reported changed status from "Open - pending review" to "Open - Fix being tested", so there's progress.

Sorry I didn't look hard enough for a similar report...

Ok, so it is in Nvidia's hands now. Thanks for the info @Brecht Van Lommel (brecht)

Sergey Sharybin (sergey) closed this task as Archived.
Sergey Sharybin (sergey) claimed this task.

Closing as this is not a Blender bug, meaning we can't do anything about it anyway. NVidia is informaed about the problem anyway.

Thanks for the report and investigation anyway!

Same for me
nvidia-drivers-370,23
kernel-4.7.2
all blender versions was crashed

From NVidia:

It has been fixed now in our development driver builds, and the fix would be available for you in the future driver release.

So, now we just wait for NVidia to release a new driver version.

Thanks for reporting to nvidia and for update here what nvidia says.

Hi all. Arch Linux just updated to Nvidia driver 370.28 and it doesn't cause Blender/Cycles to crash anymore.

Yesterday GENTOO-Linux updated to x11-drivers/nvidia-drivers-370.28 also.
Blender works fine now.
A big THANK YOU to the GENTOO-developers to include the new dirver
quickly.