Page MenuHome

Nvidia card and Cycles Render - Blender 2.77a crashes immediately
Closed, ResolvedPublic

Description

System Information (Two different computers)
System 1
Windows 10 Pro, 64bit and Graphics card Nvidia NVS 5200M, (Version 372.70)

System 2
Windows 7 Pro, 64bit and Graphics card Nvidia GeForce GTX 750 Ti, (Version 372.70)

Blender Version
Broken: Version 2.77a on both systems

Short description of error
Opening Blender caused the following error: EXCEPTION_ACCESS_VIOLATION

At first this was just opening up certain files already set up and in progress for a project, but after re-installing blender and updating Nvidia graphics card, problem extended to just opening a blank Blender file.

Error seems to be related to when files were switched from Blender Render to Cycles Render

Exact steps for others to reproduce the error
Open Nvidia Graphic card control panel, and in the Manage 3D Settings, open the Program Settings tab. Add Blender in the program customize option, change the preferred graphics processor to High Performance Nvidia processor. Open command prompt and run Blender in debug mode "blender.exe -d" to get error report

Temporary Fix
On Windows 10 System, changing Preferred Graphics Processor to Intel Integrated Graphics allows the Blender and files in question to open

Fix does not work for Windows 7 System.

Details

Type
Bug

Event Timeline

Sergey Sharybin (sergey) triaged this task as Normal priority.

We had such bug reported before (see T49113). It was caused by bug in NVidia driver which they were working on. Curious to know, is that fix expected to be in 372.70.

@Brecht Van Lommel (brecht), any ideas here?

The issue I found was on Linux, I did not hear about it affecting Windows. It's possible that the same bug ended up in this new 372.70 driver while the fix didn't?

This evening I can try installing the new driver on Windows to confirm if it's the same bug and report to NVidia.

For now users can install an older driver version to work around this I expect.

I can't reproduce this bug, on Windows 10 with NVidia GTX 960 and driver version 372.70.

Some things you could try:

  • Test running the 3 applications in this file: and see which ones (if any) crash. They initialize CUDA, OpenCL, and both CUDA and OpenCL. This could give us a clue if it's the same issue as on Linux.
  • Uninstall all graphics drivers (Intel, AMD, NVidia) and install again. There have been known issues with OpenCL installations getting corrupted when multiple graphics drivers are involved.
  • Check if it crashes with an older NVidia driver, for example a 368.x version.

I have found a fix for the Windows 10 system. I will document the steps I took in case anyone else has this problem and is looking for a fix:

I uninstalled all of the drivers, rebooted, and then re-installed a driver from Lenovo's website (a modified driver for nvidia cards in their laptop systems).

Then I went into Nvidia's control Panel, and to Manage 3D settings. From there I went to program settings and added Blender to the list, switching it from "integrated graphics" to the Nvidia card.

I opened Blender, went into User Preferences, clicked the Systems tab, and on the lower left switched to CUDA and confirmed that it was referencing the Nvidia card in my system.

Once all of that was in place I opened up one of the files that was previously crashing on me, and everything worked just fine.

I have not yet found a fix for the Windows 7 desktop system that has a GeForce GTX 750 Ti. For that I am going to try uninstalling the Nvidia driver currently running, wiping it clean, and then trying to install a lower version and see if that works.

I will post again if I find a solution.

Thanks to everyone who has looked into this thus far. I appreciate the help!

Brecht Van Lommel (brecht) lowered the priority of this task from Normal to Needs Information from User.Sep 1 2016, 10:30 PM

Which driver version do you have installed on Windows 10 now?

If it's an older on there might still be a bug in the 372.70 driver. If that's the case then I expect we'll hear about it from many users, but since I can't reproduce it, it might only happen with some specific system setup.

Brecht Van Lommel (brecht) raised the priority of this task from Needs Information from User to Normal.Sep 1 2016, 10:31 PM

The Driver Version is 354.74

It was downloaded from Lenovo's Upgrade Catalog, so it may be slightly different than what is found on Nvidia's website or from another laptop providers driver.

Kathy McNeal (kmcneal) closed this task as Resolved.Sep 2 2016, 2:12 AM
Kathy McNeal (kmcneal) claimed this task.

Windows 7 Pro desktop computer issue has been solved

Solution

Uninstalling all Nvidia drivers from system, rebooting, and installing a lower version (365.19) from Nvidia's website for the GeForce GTX 750 Ti graphics card.

Also uninstalled and reinstalled Blender 2.77a (which comes up in the programs list as 2.77.1).

Was still having the problem until in Blender's File dropdown menu, I hit the "Load Factory Settings" option to completely remove all of my previous links and preferences.

After doing all of this, Blender now opens all of the files, with CUDA enabled.

Using a lower driver that has been tested as safe to use, and calling this report solved for now.