Wrong key frames in added scene in VSE
Closed, ArchivedPublic

Description

Blender Version
Broken: 2.77.a, 2.78

Short description of error
I create a scene Scene in VSE by adding some strips with effects at specific key frames. When I import this scene in SceneAll in VSE by using

Add->Scene with use sequence enabled in the properties, the key frames are not in the right time. For instance, in scene1 key frames are at 1 and 40. When I import Scene in SceneAll, key frames still will be at 1 and 40 whatever the start of Scene in SceneAll. I was expecting another result : key frames at (1+start of Scene in SceneAll) and (40+start of Scene in SceneAll).

Exact steps for others to reproduce the error
This bug is show in the attached file.

Details

Type
Bug
Sergey Sharybin (sergey) closed this task as Archived.Sep 6 2016, 11:32 AM
Sergey Sharybin (sergey) claimed this task.

Thanks for the report, but it's quite tricky actually.

Sequencer was never designed to do recursive rendering and this feature was kind of hacked in to support Gooseberry project. Changing the way how it works now will cause regressions. Trying to make it an option will lead to confusion about how to set it all up and everything.

We have quite some design limitations in sequencer, so we'll really have to sit down and think of it's major re-designing. So while the code behaves in the way it was originally designed to (even tho it doesn't met some usecases) considering it a TODO (see [1]).

Hopefully it'll happen in 2.8 branch or maybe some other developer will drop by and pick up the development :)

[1] https://wiki.blender.org/index.php/Dev:Source/Development/Todo/Editors#Video_Sequencer

Ouch, this is quite annoying, I just hit this bug.

Are there any workarounds? Or should I go into the imported scene and shift it in time to the same position where it's being used in the master scene?

Sergey, I'd be more than willing to write a patch, if you let me know the desired behaviour. About causing regressions, don't blend file contain information on what blender version they were created in? If we had that, then we could correct the behaviour for new projects but keep the old behaviour when loading old projects. Or am I missing some complication?

Sergey, forget my last question; I see that blender files are supposed to be both backward and forward compatible, so we cannot play tricks based on the blender version.

What if we add another checkbox just below the text that now says "Original frame range: <A-B>" and call it something like "Shift all timings to new range". Well, I'm sure better names can be found, but this is not too bad, IMHO.

I've spent some time trying to undestand how this works, and I got something which is more or less working, though for some reason the image in the sequencer sometimes is updated in the wrong way.

Can some blender developer comment on what I'm doing (patch attached)?

I suspect that my approach will fail miserably if the same scene in used twice (at different start times) in another scene, because AFAIU the animations are evaluated only once. What would the correct approach be?