Page MenuHome

Color wheel and Value slider in 2.78 is "poor" ??
Closed, ArchivedPublic

Description

System Information
Windows 64 Pro, updated. AMD FX(tm) 8120 Eight Core 3.10 Ghz, NVidia GeForce GTX 760

Blender Version
Broken: (2.78 Release Candidate)
Worked: (prior version 2.77a+)

I noticed that the color picker was "poor" low quality display, totally dark on the Value bar regardless of the color chosen, and I tried the other choices in the User Preferences, none were all that much better. The color display in the square version reminded me of old 8 bit color, with large boxes. Nothing I did seemed to change the display to what I remember on previous versions.

Exact steps for others to reproduce the error
Open 2.78, choose a material for a default object, (cube) then select the Diffuse color. The picker comes up with a completely black Value Bar and no sliding up or down makes a difference.

Details

Type
Bug

Event Timeline

There was an issue in the Node Wrangler add-on that could cause the blockiness of the color picker widgets.
It was mentioned in T49090 and T49161.

To test that, start blender from the cmd (command line) with blender -d --factory-startup arguments or go to
File>Load Factory Settings

That should temporarily reset all the settings and disable all the add-ons until blender is restarted.

If the error disappears check if you have an old version of Node Wrangler enabled (imported from a previous install) or some other addon that uses some OpenGL functions in the script.

If the error still occurs during the factory setting reset session, upload the system-info.txt generated by Help>Save System Info
by dragging and dropping the file in the comment box (that will upload the file here). Also you could run blender from the cmd with the -d argument and see if there are any errors in it.

Sergey Sharybin (sergey) triaged this task as Needs Information from User priority.Sep 6 2016, 11:34 AM

Node wrangler addon was fixed and 2.78-rc1 ships the fixed version.

Does this issue happen with all the Window Draw Method options (User Preferences -> System)?

I tried the Factory Default, color wheel worked fine, thank you. Node Wrangler, downloaded the latest from their site, but the problem was still present. Turned off Asset Management and PBR Materials as I saw some error warnings in the CMD Window, and turned off Node Wrangler. Color wheel works fine. So "one" of them appears to be contributing. Thank you again.

I checked, and I have never changed the defaults. I tried them all and they all seem to work, when just going over to the 'nearby' color choices in the User Preference window, so those do not seem to be a problem. I will look forward to the next RC and see if Node Wrangler acts better. I know that Asset Manager hasn't stated 2.78 compliance yet, and I do not know about PBR Materrials, as both of these threw up 'complaints' in the CMD window. Thank you again for your response and your team fine development work.

I just installed the latest BuildBot from the Blender "Bleeding Edge" downloads. I checked, the color picker is working fine. I enabled Node Wrangler, still fine, enabled PBR Materials, still fine. Tired Asset Manager, (which the developer has stated is not yet 2.78 compliant) and the CMD window was coughing up hairballs, for the moment. Seems like your team has snuffed out this one. Congratulations. Best to you on the 2.78 release.

Julian Eisel (Severin) closed this task as Archived.Sep 7 2016, 12:11 AM
Julian Eisel (Severin) claimed this task.

Seems we can close this then :) Thanks for reporting.