Page MenuHome

Grease pencil layer new color tint not active when drawing
Closed, InvalidPublic

Description

System Information
Win10 - Quadro 4000

Blender Version
Broken: 2.78 RC1
Worked: 2.77 with old grease pencil layers

Short description of error
With the new color palette layers of grease pencil, the color tint of the grease pencil layer is no more active when painting and the color of the stroke is visible only when the mouse is released.

Exact steps for others to reproduce the error
Create a grease pencil layer, change the tint color to anything but black, change the tint factor to 1 and draw a stroke, the stroke will be black until the button is released.

or open the attached file and draw a stroke to see the issue.

Details

Type
Bug

Event Timeline

This is not a bug and works in this way by design. The tint color is considered as a modifier and only works after the release of the mouse.

While you are drawing, the color of the stroke is the current palette color, not the result of the palette + tint.

Ok, thanks. Good to know it's not a bug.
Unfortunately for our studio, we're using GP color layer only as an annotation tool in the VSE and we don't want to add complexity with color palette. If this is like that, we'll deal with it anyway! ;)

Julian Eisel (Severin) closed this task as Invalid.
Julian Eisel (Severin) claimed this task.

Seems like we can close this :) Thanks for reporting nevertheless.