Page MenuHome

Wintab Drivers no longer compatible
Closed, ArchivedPublic

Description

System Information
Windows 10 Anniversary, Intel HD 4200

Blender Version
Broken: 2.77
Worked: Only works when rolling back to previous version (1511) of Windows 10

Short description of error
Since Windows 10 updated to Anniversary, Wintab drivers are no longer compatible. I'm trying to get to the bottom of whether this is a deliberate change that developers need to adjust their code for or if it's broken on the Microsoft side.
Rolling back to Windows v1511 fixes the error.

Exact steps for others to reproduce the error
Update to Windows 10 Anniversary (v1607)

Details

Type
Bug

Event Timeline

Sergey Sharybin (sergey) triaged this task as Needs Information from User priority.

I can't reproduce the issue with WIndows 10 machine here in the studio. The only thing i did different from you is i've installed Wacom drivers after updating to v1607 (i didn't have any tablet drivers before so i kinda had to do that).

Knowing tendency of Windows to override manually-installed drivers, try re-installing your tablet drivers after update to v1607.

JoshBowman (JoshyB) added a comment.EditedSep 14 2016, 3:46 PM

It's specific to Wintab drivers that are the issue so if you're using a wacom pen or wacom pen drivers then no, that doesn't replicate the issue because Wintab is different to Wacom.

No Wacom drivers because I'm not using wacom pen tech, I'm on a Surface Pro 3 using N-Trig pen tech.

I've reinstalled the Wintab drivers after installing Windows 10 Anniversary and they didn't work, even had a tech at the Microsoft Surface Store go through the same process and reproduce the exact same issue across Blender and Krita, both of which use Wintab to enable pressure with N-Trig pens. Both stopped working after Anniversary update, even with drivers reinstalled and both work as they should again when I wiped my computer and went back to a pre-Anniversary version of Windows installed and tested at the Windows store.

Ah, thought Wacom is accessed via Wintab. Unfortunately, we don't have access to surface.

Did i understand correct Microsoft guys managed to reproduce the issue and looking into it?

JoshBowman (JoshyB) added a comment.EditedSep 15 2016, 5:23 AM

The guys at the store managed to reproduce the error but then threw it back on the developers to check that it wasn't something they needed to update on their end if the way the program has to access the drivers has changed.

I'm trying to get confirmation somehow as to whether the drivers are actually broken with the Win 10 update or whether the programs need to change the way they access the drivers (I'm not a programmer so I'm in the dark as to how this works), that way I can go back to Microsoft and say 'it's an issue with your drivers, fix it'.

Is it possible for a future version of Blender to support 'Windows Ink' API instead of Wintab??

Not sure if my edit on my last post was seen:

"Is it possible for a future version of Blender to support 'Windows Ink' API instead of Wintab?"

It was seen, but hard to keep things posted when we've got handful of developers who need to take care of both Blender itself and bug tracker. So delays in responses are inevitable :(

I didn't look up in details when exactly Windows Ink API was introduced. If it doesn't cause compatibility issues (we still have users on Win7) then it's not impossible to switch to that API. But it's still tricky to do for developers who doesn't have hardware to test the new API integration.

About testing whether WinTab is broken. Did you experience issues in other software? Maybe Gimp or Krita or even something non-opensource?

All good, I understand the busy nature of development.

As for further testing, I've tried Krita and it didn't work in Anniversary, Artrage too with Wintab drivers enabled didn't work either, only when i switched the driver off in the application did pressure start working again. Photoshop which does not use Wintab works with pen pressure because it's now on Windows Ink API according to this discussion on Reddit that I had with someone who was also testing the drivers out.

https://www.reddit.com/r/Surface/comments/521xjf/dont_update_to_win_10_anniversary_if_you_still/

Bastien Montagne (mont29) closed this task as Archived.
Bastien Montagne (mont29) claimed this task.

So this looks more like a TODO to support some new API? Together with a new gorgeous failure from Windows guys… But not a bug from our side anyway, so will close for now, thanks for the report.

JoshBowman (JoshyB) added a comment.EditedOct 4 2016, 3:18 AM

Thanks so much for the time you put into this and the future development enabling Windows Ink compatibility Sergey and Bastien. I've been using Blender more and more for personal and work projects and it's by far and away my preferred toolkit, having worked with Maya exclusively for the last 15 years.

After seeing this I tried installing photoshop trial and it indeed fixes the issue for blender (and Gimp, and Inkscape)