Page MenuHome

BGE standalone player crash when loading another file more than 32 times
Closed, ArchivedPublic

Description

System Information
Windows 10 64, Nvidia GT 425M

Blender Version
Broken: 2.77a abf6f08

Short description of error
Standalone player crashes after using the load file function more than 32 times in the same session.

Exact steps for others to reproduce the error

  • unzip the zip file
  • open 1 of the blend files
  • start the standalone player
  • press the 'W' key 33 times

Standalone player crashes consistently loading the 33rd time.

Notes:

  • tested using the logic brick actuator 'game' and a python script with 'bge.logic.startGame('//filename.blend')' having the same result
  • embedded player doesn't crash.

Details

Type
Bug

Event Timeline

Sergey Sharybin (sergey) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.Sep 13 2016, 11:17 AM

This bug is related to a python segfault, the back trace is:

#0  0x00007ffff77aecc4 in type_dealloc (type=0x2798840 <euler_Type>)
    at /var/tmp/portage/dev-lang/python-3.5.2/work/Python-3.5.2/Objects/typeobject.c:3027
#1  0x00007ffff778eff7 in free_keys_object (keys=0x37380b0) at /var/tmp/portage/dev-lang/python-3.5.2/work/Python-3.5.2/Objects/dictobject.c:354
#2  0x00007ffff778fa10 in dict_dealloc (mp=0x7fffdeaf7908) at /var/tmp/portage/dev-lang/python-3.5.2/work/Python-3.5.2/Objects/dictobject.c:1602
#3  0x00007ffff779c817 in module_dealloc (m=0x7fffdea813b8) at /var/tmp/portage/dev-lang/python-3.5.2/work/Python-3.5.2/Objects/moduleobject.c:638
#4  0x00007ffff77811ed in list_clear (a=a@entry=0x7fffdef99488) at /var/tmp/portage/dev-lang/python-3.5.2/work/Python-3.5.2/Objects/listobject.c:562
#5  0x00007ffff7784458 in list_ass_slice (a=0x7fffdef99488, ilow=<optimized out>, ilow@entry=0, ihigh=<optimized out>, v=v@entry=0x0)
    at /var/tmp/portage/dev-lang/python-3.5.2/work/Python-3.5.2/Objects/listobject.c:632
#6  0x00007ffff7785552 in PyList_SetSlice (a=<optimized out>, ilow=ilow@entry=0, ihigh=<optimized out>, v=v@entry=0x0)
    at /var/tmp/portage/dev-lang/python-3.5.2/work/Python-3.5.2/Objects/listobject.c:688
#7  0x00007ffff78334d9 in _PyState_ClearModules () at /var/tmp/portage/dev-lang/python-3.5.2/work/Python-3.5.2/Python/pystate.c:370
#8  0x00007ffff7827204 in PyImport_Cleanup () at /var/tmp/portage/dev-lang/python-3.5.2/work/Python-3.5.2/Python/import.c:426
#9  0x00007ffff78318c4 in Py_Finalize () at /var/tmp/portage/dev-lang/python-3.5.2/work/Python-3.5.2/Python/pylifecycle.c:576
#10 0x00000000013155d8 in exitGamePlayerPythonScripting () at /home/tristan/Compilation/UPBGE/blender/source/gameengine/Ketsji/KX_PythonInit.cpp:2144

Aparrently the euler_Type has an issue. I looked for specials operations made for mathutils types but i found nothing, maybe someone know better that than me.

Aaron Carlisle (Blendify) closed this task as Archived.Jun 29 2019, 2:18 AM
Aaron Carlisle (Blendify) claimed this task.

This task is being closed because the BGE has been removed in Blender 2.8.