Quicktime video file render result is corrupted
Open, ConfirmedPublic

Description

System Information
iMac (Retina 5K, 27-inch, Late 2015) I have tried on older macs as well.

Blender Version
2.77, even tried of 2.74

Short description of error
After a complete render, the file (quicktime) - (h264) is only playable through playing the preview on finder. Played on quicklime it is just black. I experienced this error only the last 5 months.

Exact steps for others to reproduce the error
The file is ready to be put on render. it does not matter if full animation is completed or cancelled before.

Thank you.

Details

Type
Bug
Bastien Montagne (mont29) changed the title from "Corrupted file after render" to "Quicktime video file render result is corrupted".Sep 19 2016, 10:25 AM
Sergey Sharybin (sergey) triaged this task as "Incomplete" priority.Sep 20 2016, 11:19 AM

Have you ever been able to export QuickTime video from Blender? If so, does that Blender version still work? Did you update mac recently? (current guess is that it might be related on the QTKit framework removed from recent builds).

@Martijn Berger (juicyfruit), are you able to test/reproduce the issue?

Brecht Van Lommel (brecht) raised the priority of this task from "Incomplete" to "Confirmed".Sep 25 2016, 2:59 AM

I can confirm the issue in Blender 2.77. If I render at half resolution, change the video codec from H.264 to JPEG, or lower the quality from 100% to 80% it works.

I don't know if we are using the API wrong or if something broke in OS X. I can't spot anything wrong in our code so far.

At this point maybe we should discuss removing support for QuickTime in 2.8?