Page MenuHome

Parts of the mesh works as a boolean / does not show up in object mode.
Closed, InvalidPublic

Description

System Information
Operating system and graphics card
Windows 10

Blender Version

2.78

Short description of error

I'm modeling something where I need to use boolean modifier to create windows and doors to my model. It works nicely, but now when I created some details to my object in edit mode, it seems that they also works as boolean if they are touching the certain part of my object. If I move them little, they seem to work nicely. I'm not exactly sure if this is a bug, or something else, but no one knew nothing about it, so I had no choice than create topic here.

https://blenderartists.org/forum/attachment.php?attachmentid=455025&d=1475241790
https://blenderartists.org/forum/attachment.php?attachmentid=455026&d=1475241801
https://blenderartists.org/forum/attachment.php?attachmentid=455027&d=1475241813

Exact steps for others to reproduce the error

Steps are not known. I cannot reproduce it, but here is a blend file, that has the error visible.
https://www.dropbox.com/s/4dqgkyfufxifsbi/tuulimyllyj%C3%A4.blend?dl=0

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) closed this task as Invalid.
Bastien Montagne (mont29) claimed this task.

Your mesh is non-manifold, with multiple closed volumes intersecting each others… Booleans need a clean, sane non-manifold, closed, non-intersecting volume to give predictable results. Otherwise, there will always be some cases in which they fail (note that new BMesh boolean solver in 2.78 seems to give slightly better results here - totally 'correct' from a human point of view though).