Page MenuHome

lost Wacom functionality
Closed, ResolvedPublic

Description

System Information
win 7 64 bit
16gb
GTX980

Blender Version
Broken: 2.77a, 2.78
Worked: 2.77

Short description of error
updating to 77a lost some Wacom functionality. 78 has too

Exact steps for others to reproduce the error
installed 77a as usual, it went into the same folder as always etc. tried using the pen and SHFT/CTRL for view pan/zoom, didn't work.
reinstalled 77, functioned ok.
installed 78, same thing. loaded up previous settings, zoom/pan doesn't work w/ the Wacom. nib registers as L Click [correct] and pressure seems ok in Sculpt mode. Button mapped to R Click seems ok, buttom mapped to Middle Click seems to register as L Click.
have tried "emulate 3 button mouse" on and off, nothing. have tried uninstalling and resinstalling, same fault.
original install gave me an error about a missing SDL2.dll - a message here [IIRC] said to do a repair on the MSI, i did and that let me install, not sure if this is a factor.

pen is Wacom Intuos Pro Touch Medium, still works 100% w/ everything but Blender.

Details

Type
Bug

Related Objects

Event Timeline

Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Normal.Oct 8 2016, 4:08 PM

Not sure what to do here… We need a dev with a Wacom and Windows to investigate here. :|

hi,
this can be closed. turned out to be some odd error in the Wacom props - don't know what or how as i've installed each version of Blender the same, but for some reason it was showing "blender-app" in the Prefs set up and not the Blender logo

cheers

Brecht Van Lommel (brecht) closed this task as Resolved.Oct 8 2016, 6:24 PM
Brecht Van Lommel (brecht) claimed this task.