Page MenuHome

Blender chrashes after Cuda 8.0 update
Closed, ArchivedPublic

Description

System Information
Operating system and graphics card

Linux Mint 17.3, GeForce GTX 970

Blender Version
Broken: Blender 2.78
Worked: Actually none of blender versions are working now

Short description of error

After Cuda 8.0 update installed, all versions of Blender that I have are crashing. I see only blank interface for a second and then program terminates. If I start Blender from console, I see standard messages about reading prefs, bundled python then "Writing: /tmp/blender.crash.txt " and "Segmentation fault". That crash file contains following lines:

Blender 2.78 (sub 0), Commit date: 2016-09-26 12:42, Hash 4bb1e22

backtrace

blender(BLI_system_backtrace+0x1d) [0x1b6269d]
blender() [0x11bc81e]
/lib/x86_64-linux-gnu/libc.so.6(+0x36cb0) [0x7f80cf9bbcb0]
/lib/x86_64-linux-gnu/libpthread.so.0(pthread_mutex_lock+0x4) [0x7f80d0fad404]
/usr/lib/x86_64-linux-gnu/libnvidia-opencl.so.1(+0x1db008) [0x7f80b339d008]
/usr/lib/x86_64-linux-gnu/libnvidia-opencl.so.1(+0x28f671) [0x7f80b3451671]
/usr/lib/x86_64-linux-gnu/libnvidia-opencl.so.1(+0x28f7e5) [0x7f80b34517e5]
/usr/lib/x86_64-linux-gnu/libnvidia-opencl.so.1(+0x1e0cb4) [0x7f80b33a2cb4]
/usr/lib/x86_64-linux-gnu/libnvidia-opencl.so.1(+0x1e24e7) [0x7f80b33a44e7]
/usr/lib/x86_64-linux-gnu/libnvidia-opencl.so.1(+0x1b5c66) [0x7f80b3377c66]
/usr/lib/x86_64-linux-gnu/libnvidia-opencl.so.1(+0xb4f3d) [0x7f80b3276f3d]
/usr/lib/x86_64-linux-gnu/libnvidia-opencl.so.1(+0xb4ed8) [0x7f80b3276ed8]
/usr/local/cuda-8.0/targets/x86_64-linux/lib/libOpenCL.so(+0x2022) [0x7f80b3bfd022]
/usr/local/cuda-8.0/targets/x86_64-linux/lib/libOpenCL.so(+0x3d42) [0x7f80b3bfed42]
/usr/local/cuda-8.0/targets/x86_64-linux/lib/libOpenCL.so(clGetPlatformIDs+0x20) [0x7f80b3bfe4d0]
blender() [0x20fd2b4]
blender(_ZN3ccl18device_opencl_infoERNS_6vectorINS_10DeviceInfoENS_16GuardedAllocatorIS1_EEEE+0x39) [0x20ffdb9]
blender(_ZN3ccl6Device17available_devicesEv+0x99) [0x20e8549]
blender() [0x1ff6985]
blender() [0x1ade8b8]
blender(RNA_property_enum_items_ex+0xf9) [0x19c7619]
blender(RNA_property_enum_items+0x15) [0x19c7645]
blender(RNA_property_enum_identifier+0x26) [0x19c7bc6]
blender() [0x15a9cdb]
blender(pyrna_prop_to_py+0x100) [0x15b1d40]
blender() [0x15b2090]
blender(PyEval_EvalFrameEx+0x31f8) [0x2be0238]
blender(PyEval_EvalFrameEx+0x7cb1) [0x2be4cf1]
blender() [0x2be67d2]
blender(PyEval_EvalCodeEx+0x48) [0x2be68d8]
blender() [0x2b5319f]
blender(PyObject_Call+0x5a) [0x2b29d5a]
blender() [0x15b13aa]
blender() [0x1ac9a3c]
blender(ED_region_panels+0x27f) [0x1496a0f]
blender() [0x11e9088]
blender(ED_region_do_draw+0xa16) [0x1495be6]
blender(wm_draw_update+0x637) [0x11c1c37]
blender(WM_main+0x28) [0x11bd438]
blender(main+0x3b3) [0x11620c3]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5) [0x7f80cf9a6f45]
blender() [0x11b96c9]

Exact steps for others to reproduce the error
Install Cuda 8.0 update, and try to start Blender.

Details

Type
Bug

Event Timeline

Could be the same issue as T49113. What is the exact NVidia driver version you have installed? Version 370.23 specifically had a bug that should not happen in newer/older versions.

I'm also not sure what you mean by "Cuda 8.0 update", I guess the CUDA toolkit? Note that you only need the CUDA toolkit for building Blender yourself, and installing the driver bundled with that toolkit is typically not needed.

I have Nvidia 361.93.02 driver and yes I'm taking about toolkit because I couldn't make Cuda work on my system until I've installed a whole toolkit :(

Not directly related to the problem you mention, but at least you can use GPU compute until you can solve the problem. If you are using nvidia drivers installed from repos, I recently read that in Linux Mint you still need to install 'nvidia-modprobe' package. You look for that package, install it and reboot the system. Remember that you also must have installed 'libcuda1' related package. And of course you should use official Blender downloaded from official Blender 3D website which include precompiled CUDA kernels (tar.bz2 file for Linux). Extract to a folder and run there 'blender' file.
You can search about 'nvidia-modprobe' and Blender in Google, there is much written.

Sergey Sharybin (sergey) triaged this task as Needs Information from User priority.

Make sure you've got libcuda1 installed.

As for the crash:

  • Is it official Blender build from blender.org / builder.blender.org ?
  • Try installing clinfo and run it and see if it gives any issues as well.
Sergey Sharybin (sergey) closed this task as Archived.Oct 18 2016, 12:21 PM
Sergey Sharybin (sergey) claimed this task.

There is now more than 5 days without reply.. Archiving due to the policy of the tracker for until requested information is provided.

It's really important to collaborate between developers since it's the only way we can troubleshoot issues.