Page MenuHome

blender crashes after adding texture node to compositing tree
Closed, ResolvedPublic

Description

System Information
System 1: Windows 10 with NVIDIA GTX1070
System 2: Windows 10 with Intel HD4000

Blender Version
Broken: 2.78a (e8299c8); also tested daily build 2.78 10a25b6
Worked: 2.78

Short description of error
Directly after adding a texture node to the compositing node tree blender crashes.

Exact steps for others to reproduce the error
Start up blender, open a node editor (independent of rendering engine), enable "Use Nodes" and add a input>texture node (with menu, shortcut or searchbar, it doesn't matter).

The console says: Error: EXCEPTION_ACCESS_VIOLATION

Event Timeline

Caused by the fix for T49789 (m_texture is null)

Bastien Montagne (mont29) triaged this task as Confirmed, Medium priority.Oct 31 2016, 2:15 PM
Grant Borodin (tashtego) reopened this task as Open.

It's still here
Adding Texture Node in compositor crashes blender

Archlinux
Blender version 2.78a

cat /tmp/blender.crash.txt
# Blender 2.78 (sub 0), Commit date: 2016-10-24 12:20, Hash e8299c8100
bpy.context.space_data.tree_type = 'CompositorNodeTree'  # Property
bpy.context.scene.use_nodes = True  # Property
bpy.ops.node.add_node(type="CompositorNodeTexture", use_transform=True)  # Operator

# backtrace
blender(BLI_system_backtrace+0x30) [0x140f9b0]
blender() [0xa43869]
/usr/lib/libc.so.6(+0x330b0) [0x7f8dd2bb10b0]
blender(_ZN20TextureBaseOperation19executePixelSampledEPfff12PixelSampler+0x98) [0x10807a8]
blender(_ZN16PreviewOperation13executeRegionEP4rctij+0x23b) [0x10841db]
blender(_ZN9CPUDevice7executeEP11WorkPackage+0x7a) [0x106122a]
blender(_ZN13WorkScheduler18thread_execute_cpuEPv+0x2d) [0x106020d]
/usr/lib/libpthread.so.0(+0x7454) [0x7f8dd3127454]
/usr/lib/libc.so.6(clone+0x5f) [0x7f8dd2c667df]
Sergey Sharybin (sergey) closed this task as Resolved.Feb 3 2017, 4:55 PM

Sorry, but we don't have time machine to. Blender 2.78a was releases 24 Oct, the fix was committed 3 Nov.

It'll be in 2.78b update we're planning to do today tho.