Page MenuHome

Shortcuts won't work
Closed, ArchivedPublic

Description

System Information
Intel Core i5 6600k CPU@ 3.5Ghz
Ram: 32 GB
Video - 2 x GTX750Ti
Windows 10 - 64 Bit OS

Blender Version
Broken: (2.78 4bb1e22)
Worked: (optional)

Short description of error

Ctrl + 1,2,3,z shortcut won't work properly.

Exact steps for others to reproduce the error

  1. Open Blender
  2. Create an object
  3. Try to use short key for - Subsurf modifier (Ctrl+1; or Ctrl+2; or Ctrl+3 - they don't work at all)
  4. Try to use it above 3 - Ctrl +4; or 5; or 6 - worked
  5. Camera shortcut connected to Ctrl are not working also
  6. Ctrl +z also is not working at all, even Object/ Undo operation won't work

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Oct 31 2016, 2:09 PM

This looks like a corrupted settings somehow, please try to start Blender in factory settings (--factory-startup commandline option) (this will ensure whether this is a userpref or addon issue or not).

Hello,
I load the factory settings, and also I re-install Blender 2.78. I still have the issues with shortcuts - Ctlr+1; Ctlr+2; Ctlr+3. What shall I do?

Hrmmpf… can you check with another keyboard? Or can you check those shortcut (ctrl-z etc.) work with another application?

Hello Bastien,

I've checked already my Ctrl+key combination with all other applications and it works. I re-installed again, and now the problem is only on Ctrl+1; Ctrl+2; Ctrl+3 ...

But the combination works with -> Ctrl+4; Ctrl+5 etc. and above.

Tell me what can I do please. ..

You may try to run Blender with --debug-events option (from command line), just hit ctrl-1, and then e.g. ctrl-4, and close Blender.

Then please attach here (as a text file) the whole output from the command line, will list all events received by Blender, lots of noise, but will tell us if it gets those missing ctrl-1 etc. events.

Oh, and might be obvious, but did you check in your user preferences, Input tab, that ctrl 1 etc. shortcuts were correctly defined and assigned too?

Hi again,
I do not understand what should i do.

Where and how to start this [--debug-event] operation,? Is it in Command prompt? or somewhere in Blender?

You start Blender from you command line, giving it --debug-events as option.

So type something like:

C:\path\to\blender.exe --debug-events

And then do your shortcuts testing (as quickly as possible), close Blender, and copy what was printed in the console into a text file and attach it here.

Hello Thanks, I did it.

Just to mention that the last installed blender version in my machine is 2.78a, Hash: e8299c8, Date 2016-10-24, time 12:20

Here I did it again, with the following commands from Ctrl+1 to Ctrl+4, it may help more than the previous one.

Thanks, so looks like we are missing 'press' events for keys 1/2/3… Not sure what to do from there, we'd need some windows people to check whether they can replicate the issue, but imho there is something wrong either with your keyboard or OS setup somehow.

Also, please check with another keyboard.

I have tested using 2.78a factory settings in Windows 10 64 bits and all is working fine.

Unable to reproduce the error.

Odds are if we're not getting key-presses, some other application installed a keyboard hook and uses those keys for it's own use. it's hard to tell which app this is though....

Hey guys, I remove my current install several times and try to re-installed again and again, and the result is same... :(
Is there a way to look over the system which programs use same short keys?

I make a test with this Windows hotkey explorer - the program which I'm not recommending you to try, however in my case the Ctrl +1/2/3 were empty...

Please look at the attachment example for "Shift-PrtSc" - empty..
https://i.stack.imgur.com/eCWcT.png

Please, give me suggestion to resolve this problems?
Thank you in advance

@Ivaylo Gogov (ivaydesign) from that Ubuntu link, the problem was that those shortcuts were reserved by the OS (for dragging the windows around in the OS compositor/WM).
The proposed solutions were to change the OS shortcuts through a configuration program or to change Blender ones.

Hello Vuk,

The problem is that I already try this scenario, I change the short key ctrl+1/2/3 and won't work at all, by the way in same time photoshop Ctrl+z working fine, notepad Ctrl+1 work also.

Like I've mentioned, after the first few factory resets, I decided to uninstall completely blender from the root, + the folder from app/data/..
And after that I reinstalled again, changing the short keys - and it is the same result.

Do you have the GFE - GeForce Experience that comes with the Nvidia video driver enabled / installed ?
Should be some capture software or whatever bloatware is shipped with the driver.

There are some reports on GeForce forums that it can cause the ctrl + 1, 2, 3 to stop working.

Hello,
Can you send me the link, I've been trying to find something but I couldn't. Yes, I have GFE - experience and I'm using the capturing options from time to time, but so far I haven't found any problem with that. Maybe Nvidia changes something.. which occur this issue.
I'm still looking to resolve the problem.

Thank you for the hint!

@Ivaylo Gogov (ivaydesign)

Yes, here is one link:

https://forums.geforce.com/default/topic/972645/geforce-experience/nvidia-share-hotkeys-on-3-1-0-44-making-share-worthless/1/

It's quite possible that the share feature bugs out and takes control of the ctrl+1,2,3 keys.

Bastien Montagne (mont29) closed this task as Archived.Dec 16 2016, 8:19 PM
Bastien Montagne (mont29) claimed this task.

In any case, this is out of Blender's hands, if it does not receive events it cannot do anything… Thanks for the report anyway.