Page MenuHome

Middle Mouse button for Rotate 3D view does not work (Mouse: Logitech MX Anywhere 2)
Closed, ArchivedPublic

Description

System Information
Win10 Home 64-bit
Toshiba Portege Z935
Intel Core i5-3317U @ 1.70GHz
4.00 GB

Blender Version

Broken:
2.78a Hash: e8299c8
2.78 Hash: -- uninstalled this version. Sorry, no hash --
2.63 Hash: r46461:46487M

Worked:
2.77 Hash: 22a2853
2.76b Hash: f337fea
2.76 Hash: 48f7dd6
2.75 Hash: c6b042b
2.74 Hash: 000dfc0
2.72b Hash: 9e963ae

Short description of error

Rotate 3D view with middle mouse button does not work. Assigning rotate view to middle mouse button in user settings does not work. It can however be assigned to all other mouse buttons just fine.
The mouse in use is: Logitech MX Anywhere 2

Exact steps for others to reproduce the error

Start up Blender and use default cube that shows up. Select cube with right mouse button and try to rotate (does not work)
Go to : File --> User Prefs
Menu item 'Input' --> 3D View --> 3D view (Global) --> Rotate View
Try to reassign button by clicking current selection and them the middle button on the mouse. The new setting does not register. It does register with all other buttons.
Manually selecting the Middle button does assign it to the rotate function but actually using the button does nothing (as in the view does not rotate).
The same behavior occurs in v2.63 and the previous 2.78. I've gone back to 2.77 for now but are eager to move to the latest version due to the new features.
I did a brief search for this issue but didn't find (or missed) anything about this.

I am not a developer, just a user, and registered to report this.

Thank you
Christian

Details

Type
Bug

Event Timeline

Go to file -- preference -- input -- left side mouse-- emulate 3 button mouse (tick on)

save as default below
Now hold the alt key on keyboard and with the mouse hold the left mouse and rotate ur view. If u want to pan same way hold the alt+shift and the left mouse and pan.

Note : it work for all versions

Thx for the reply but this doesn't fix the issue, it's just a work-around.
Everything works just fine in the versions listed in the original post.

Something has changed between v2.77 and v2.78/2.78a.

Thank you.

i'm using am orginal microsoft optical mouse, middle button (pusshing scrol wheel works).

You might try to install X-mouse control its some freeware app that has been made especially to deal with mouses with more then 2 buttons. as a bonus it can be configured per program. and it supports a lot of mouses even those that dont seam to work well under windows

running latest build of 20-11-2016 windows 10

Thx for the tip. I might have to try it.
Logitech supplies the same software for the 'MX Anywhere 2' mouse.

Is anyone actually looking into this issue? There must be something wrong since most recent versions up until the latest 2.78 releases works just fine.

Thank you.

Joey Ferwerda (TheOnlyJoey) closed this task as Invalid.
Joey Ferwerda (TheOnlyJoey) claimed this task.

It seems that there has been no significant changes to the input code between the mentioned blender versions, this is also not testable for the developers since they don't own this particular device.

If a HID device is very specific and uses non-standard layouts, this is not something that is up to Blender to maintain, since it uses non-standard functionality.
I would recommend using the Logitech software that came with the mouse to load a standard profile for the scroll button.

Closing.

Thanks for at least looking at this.
It's unfortunate that the 'no significant' change has broken the code. With the awesome new features in the works for v2.80 I hope that version works again.
The Logitech MX Anywhere 2 is not an uncommon exotic device and I do use the Logitech software and drivers for it already. I am no C/C++ programmer but I'd be willing to try to compile Blender from source to see what happens if the v2.77 code for device input was grafted back onto the v2.78 branch but I would need to know where to look.

This still doesn't work in v2.78b but works just fine in v2.77.

Still nobody want to look into this?

so on the MX Anywhere 2 clicking the scroll wheel lets you go from "slow" to "fast" scrolling. It doesn't actually produce a "middle click". It seems you cant program it to either. the gesture button on the other hand can be programed to middle click. Create a blender app profile in the L{F591602}ogitech settings and remap the gesture button to middle click. (screenshot attached)

After only a few minutes I realized I like having the middle click separated form the scroll wheel.

Finally a post from an actual user of the MX Anywhere 2.

Yes, it is correct that pressing the wheel changes mode between smooth (fast) and stepped (slow) scrolling. Also pressing the wheel can not be used to generate a 'middle click'.
However, the wheel can be pushed sideways (both left and right) and that is the action in question.
In the versions listed as 'working' in the original post, pushing the wheel left or right would register in the Blender prefs allowing the view to be rotated when the wheel is pushed. In the versions listed as 'Broken' this does not work.

Apparently the initial post has been misunderstood from the beginning. I do appreciate the friendly suggestion made earlier here but those are beside the point.
I will try the latest option suggested by Kyle Geisler. Thank you for the picture link. It makes it clear to everyone what the mouse looks like.
The additional buttons on the side of the mouse do work and can be assigned to rotate the view but the ergonomics doesn't work as well as using the sideways motion of the mouse wheel.

Why does it work in some versions of Blender but not some other? In 2.77 it works just fine but not in 2.78. Something in the code has clearly been changed.

Thx again,
Christian Holmstedt

Best I can figure out on that is keystroke assignment, 4 and 6 mapped to left and right scroll orbits in increments with each click. not great but similar. I'll add, I discovered ctrl-alt-scroll orbits freely almost seems more useful than middle button for my original issue. :) good luck.

Thx, but again....... it's not an answer to why it doesn't work as it should.

I tried the latest suggestion and it did not work.

I give up. This is not and probably will not be looked into. Too bad a $70 mouse won't work...... where it once did.

A slight correction.

"... the gesture button on the other hand can be programed to middle click."

This option does work and after using it for a while is sufficiently comfortable.

Cheers & Thx.
Christian

(...) I'd be willing to try to compile Blender from source (...)

That can help a lot. More specifically you would do a bisect to pinpoint which commit broke the device for you. There is always a chance that the problem is a library update from Blender, not something directly related to Blender's code.

If you want to pursuit this idea (building blender and bisecting the code) go to #blendercoders on IRC for help with this.

Just to complement:

  1. Try building blender with master, to make sure you have all the requirements to build blender

The problem (bug) should be present in this build.

  1. Try building blender with version 214e384fc4ac0924fcad26f5eb64fc9e4c24b8a8 (this is the equivalent to 2.77a)

The problem (bug) should not be present in this build.

  1. Do a bisect with:

git bisect start
git bisect bad da8f5d6eac58f18193fdfd22e35fee5e1a13f12b
git bisect good 214e384fc4ac0924fcad26f5eb64fc9e4c24b8a8

It's roughly 10 steps. Which means you will need to build Blender approximately 10 times until you get the culprint. For questions and assistance with that, check #blendercoders and point anyone to this reply!

Sergey Sharybin (sergey) closed this task as Archived.

There might be some change indeed which caused issue with your particular mouse, but lot's of other mouses are working just fine here in the studio. This means it's something in particular with your hardware, which we don't have access to and can not troubleshoot.

If you follow @Dalai Felinto (dfelinto)'s steps and provide revision which broke Blender we'll be happy to investigate further, but currently we can't do anything.

@Felix Schlitter (dalai) Felinto (dfelinto)
@Sergey Sharybin (sergey) Sharybin (sergey)

Compiling Blender will have to be left for the future. I don't think I have the skills to do that but thx for the steps about how to do it. <thumbs_up>
As of now the button just below the mouse wheel works fine and I'll stick with it for the moment.

For posterity - The Logitech MX Anywhere 2s mouse middle mouse button also doesn't work with Blender 2.80.
The Logitech "Options" software does not appear to help in any way. I am returning the $80 product.