Page MenuHome

Not being able to access render output files of Blender v.2.78 using windows explorer - Windows 10
Closed, ArchivedPublic

Description

System Information
Wİndows 10, with all updates as of 30.10.2016 - NVIDIA GeForce GTX 950M

Blender Version
Broken: 2.78a
Worked: 2.61

Short description of error

Exact steps for others to reproduce the error
On one of our Windows 10 PCs we are not able to access render output files of Blender v.2.78 using windows explorer: The file is listed in the file selection dialog in Blender, but is not visible to Windows.

It seems that this behavior is observed by some other people in the net as well, and so far the only solution seems to be to do a repair reinstall Windows.

Fearing other complications of a windows repair, we looked further into the problem.

We checked every previous blender version until we were be able to locate a version that does not exhibit this problem, and found that v.2.61 does not have this behavior.

So, on a particular PC, render output files of Blender 2.62 and above are created, but not visible in Windows Explorer (display of hidden and system files enabled). Output files of 2.61 are visible on the same PC.

Can this be a side effect of a change in output file creation routines when switching from v.2.61 to v.2.62?

Best regards,
Arifi Koseoglu

Details

Type
Bug

Event Timeline

couple of questions.

Are you running explorer and blender as the same user ?

Are you storing files to a network location ?

Do you have windows offline files enabled ?

Hello Martijn,

Are you running explorer and blender as the same user ?

Yes

Are you storing files to a network location ?

Nope. They are stored on the local hard disk

Do you have windows offline files enabled ?

:) Actually, first I had to google the term to learn what it is. After that we checked and it is not enabled. However, since everything is local, would this have an effect?

Regards,
-arifi

As an additional note, I wish to underline that this all happens on the same pc. So, on this particular PC any rendering output created with Blender versions > 2.61 are not visible in Wİndows Explorer. On the same PC all rendering output files created with Blender versions <= 2.61 are visible in Windows Explorer.
Kind regards,
Arifi Koseoglu

PS. If it will be of any help, I can try to arrange a teamviewer session for you to look into the situation.

Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Normal.Nov 4 2016, 9:26 AM

That’s a very odd issue, but imho if it was a blender one much, much more users would be complaining, so this must be something wrong with your Windows installation somehow (also the fact that repairing it fixes the problem points in that direction)… Anyway, we need a way to reproduce the issue, otherwise we cannot do anything about it.

Side question: does it also happen if you save some other file from blender (some physics cache? a new image from Image Editor? etc.).

Hi Bastien,
What draws my attention is that on the same Windows installation, the Blender versions <= 2.61 are able to export the render file in a way also visible in windows explorer, while the versions >= 2.62 cannot. Even though it may be a problem on the Windows side, the fact that one Blender version's export is visible and the next version's export is not suggests that there is a change in file handling between these two versions that triggers the odd behavior..?
As to your side question: Yes, we can successfully save an image from Image Editor, also in the versions where we experience the problem with the render output file.

Bastien Montagne (mont29) closed this task as Archived.Mar 19 2019, 9:01 PM
Bastien Montagne (mont29) claimed this task.

We appreciate the effort that goes into making bug reports, but to be able to fix bugs we have to be able to redo them.
If there is anything you can provide to help others to reproduce the problem, be sure to include it.