Wrong reflection with dupli spot lamp
Closed, ArchivedPublic

Description

System Information
Win 7
I7-5820K
GTX780 ti (368.69)

Blender Version
Broken: 2.78 1ee43c5
Worked: (optional)

Short description of error
I'm using a Spot lamp with a DupliVerts, but the reflection of the dupli seems wrong.
The reflection of the dupli lights are only in the range of the original Spot lamp :


Exact steps for others to reproduce the error
Open the file and render the bottom view.
In the Lamp properties, play with the size of the spot to hide or reveal the reflection of the dupli lights.

Sorry if it's not a bug and thank you for your hard work !
C.

Details

Type
Bug

Spot lights don't work well with non-zero size, not just in Cycles but the light geometry as defined by Blender seems problematic.

The spot cone starts with radius 0 from the center of the light, but it should start with a radius large enough to encompass the size of the spot light, otherwise part of it will be cut off in reflections like this.

Sergey Sharybin (sergey) closed this task as "Archived".Feb 27 2017, 5:25 PM

There is nothing to do with dupli-vert nature of light, you have same exact behavior when making light real. And reason of that @Brecht Van Lommel (brecht) already mentioned,

Considering it a TODO as a known limitation of spot lights. Thanks for the report anyway!