Page MenuHome

Textures upload issues and feedback
Closed, ResolvedPublic

Description

From some online feedback (could be refactored in better tasks):

I noticed problems with uploading textures

Problem 1:
When trying to upload (button "save changes") i get this error:
"The submitted data could not be validated."
it works right until i want to save it.

Problem 2:
I also noticed that canceling an upload creates an empty texture (which i mentioned in the last mail, producing wrong counts)
There are "empty textures" in different categories now. (for example category fabrics has much empty textures now)

These come from:

  • a few mistakes i made, causing me to cancel and restart an upload.
  • problems with uploading today and yesterday (see problem 1)
  • discovering the problem when canceling an upload

Event Timeline

Sergey Sharybin (sergey) lowered the priority of this task from Needs Triage by Developer to Normal.Nov 8 2016, 10:45 AM

Are these issues still valid?

Francesco Siddi (fsiddi) closed this task as Archived.Jun 15 2017, 7:39 PM

These were just some glitches in the texture upload workflow. I just tested a few variations of uploading and canceling upload of textures and it works correctly. Since this can't be reproduced in a reliable way, I will archive.

Apparently the issue is not entirely fixed:

Some feedback from Blender Cloud user:

If an upload is canceled it still creates "empty textures" and leads to a wrong number of items in the header (for example category bark has now 20 textures in it, but in the header it says "22 items").
I tested it again, before uploading them there were 19 textures in this category, showing me 19 items.
Here I have created a list where i found these differences
Bark 22 / 20
concrete 61 / 59
eyes 18 / 17
fabrics 72 / 64
ground 78 / 69
plants 80 / 76
rocks 43 / 42
wall 23 / 22
wood 56 / 54 + subfolder