Linux AMD drivers UI glitches when Window Draw Method is set to automatic
Closed, ArchivedPublic

Description

System Information
Ubuntu 16.04 with AMD 280x and mesa 13.1.0-devel

Blender Version
2.78a

Short description of error
Blender UI is artifacting badly when hovering over UI elements or rotating 3d view.

Solved by launching with the command LIBGL_DRI3_DISABLE=1 blender or in blender to Blender User Preferences - System - Window Draw Method and change to Triple Buffer.

Freedesktop bug report: https://bugs.freedesktop.org/show_bug.cgi?id=97059

Exact steps for others to reproduce the error
Use AMD and mesa drivers
Start blender with Window Draw Method set to automatic.
UI should have bad artifacting.

Change Window Draw Method to Triple Buffer
Restart blender
No UI problems

Details

Type
Bug

This does not sound like a blender issue but rather a GPU driver issue.

This does not sound like a blender issue but rather a GPU driver issue.

No its a blender issue not choosing triple buffering when using mesa and DRI3.

Look in,
source/blender/gpu/intern/gpu_extensions.c
source/blender/windowmanager/intern/wm_draw.c

Sergey Sharybin (sergey) closed this task as Archived.Nov 8 2016, 10:10 AM
Sergey Sharybin (sergey) claimed this task.

This is an OpenGL issues. While our automatic detection might be improved, the timelife of this is rather short. The plan is to switch to a triple buffer in blender2.8 branch.

Trying to fix this in master now will either cause breakage for someone else or lead to huge amount of time verifying it works on all the hardware.

So i would suggest to simply ignore this, unless someone really wants to dedicate time for this.

Putting on the radars of @Mike Erwin (merwin), @Dalai Felinto (dfelinto) and @Brecht Van Lommel (brecht) who are involved into this area.

Archiving as a TODO.

Just curious, where do you expect triple buffer _not_ to work? Apple's OpenGL implementation I suppose?

For a long tie it were AMD cards, but nowadays they seems to be fine. There were also problems with Intel cards, especially GMA series. Apple's OpenGL i do not know details.

We are currently working on a complete re-work of OpenGL in blender2.8 branch, where we can just assume triple buffer an essential thing to run Blender, but we can't do it yet in the master branch. So have some doubts it's benefitical to spend time solving the issue there. Especially when it's easy to break compat (keep in mind, the policy is 10 years old hardware and 5 years old software is to be supported).

You are mentioning it is an issue with 13.1.0-devel version, is it an issue with the current stable release version of the driver?

@Edward O'Callaghan (funfunctor) Have you tried the blender2.8 branch? I did some changes there which are not in master but *could* be ported.

Tested with AMD and NVIDIA cards on latest Fedora & its default Mesa. I have not tried latest Mesa.

Triple buffer works fine on Mac too btw.