transition NLA track breaks animation of armature with dependencies
Closed, InvalidPublic

Description

System Information
Windows 7

Blender Version
Broken: current daily build (11-13-16) and 2.78 and RC versions
Worked: not sure

Short description of error

I know there are many cyclic dependencies in this rig but it animates very well. There's a tongue that also has cyclic dependencies that slides out by pulling the first bone (others are forced to follow it and it makes a sliding movement), so it looks messy but it's all pretty logical (barring dependencies) as far as I can tell and the animation results are great.

But when I use a transition NLA track it breaks the animation that is otherwise exactly what I want (barring updating mistakes sometimes).

I downloaded a daily build to enable new dependency graph to see if it would fix the issue, and some parts function much more fluidly (like the hand) but it breaks the animation overall.

I know this is a hacky rig but it functions really well. So wanted to call general attention to things that seem broken, may be in development, or would be great to be able to work out. Blender is amazing software, thank you folks!

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

  1. open attached blend file

A) advance in the timeline to the transition track and the animation will break.

B) enable depsgraph and some things will be more fluid (right hand control is selected in pose mode) but the movement is incredibly erratic

C) additional mini bug report observation: tabbing into tweak mode on 'big breath' NLA track and moving around unpinned breaks the armature also. keeping it pinned works.

-Figured I'd share this as well for those working on depsgraph to see if it might help anything in use case scenarios.

Thank you again sincerely!

Details

Type
Bug

To clarify, it wasn't that the daily build broke it, I tried first in 2.78 and know there was working being done on depsgraph so grabbed the latest build to check.

Sergey Sharybin (sergey) lowered the priority of this task from "Normal" to "Incomplete".Feb 27 2017, 11:10 AM

*Any* of dependency cycle will cause non-deterministic update of your rig. It might or might not work.

  • If you're using old dependency graph, consider testing your wile with the new one (--enable-new-depsgraph command line argument).
  • What exactly means "animation will break" ? We see this file first time and have no idea how it is intended to look.
  • Can the issue be reproduced with a simpler rig (with handful of bones)?

As I guessed before opening the file (and confirmed afterwards), it looks like you're running into several things here:

  1. If you've got cyclic dependencies, expect to see errors if you do not strictly advanced the timeline in forward order, and/or if you ever cancel transforms.
  2. The Transition track assumes that the channels you've got keyed on strips A and B both have the same set of channels to blend between.
  3. Make sure that if there are some channels which you only key in a "later" occurring strip that you've got that property keyed in some low-down strip that spans the entire timeline. For example, to avoid trouble with controls glitching out (i.e. usually scaling to zero) you'll typically want to ensure that at the bottom of the stack you've got a "Rest Pose" strip that has a keyframe for the "default" value for every property you have/will keyframe anywhere in that NLA stack, and that this strip is set to extend forward and back.
Bastien Montagne (mont29) closed this task as "Invalid".Mar 14 2017, 3:38 PM

More than a week without reply. Due to the policy of the tracker archiving for until required info/data are provided.