Page MenuHome

Objects added in 'Local view' don't get assigned to any layer
Closed, InvalidPublic

Description

System Information
Windows 10 64-bit, Nvidia gtx 570 (render), Nvidia gt 610 (display)

Blender Version
Broken: 841f3e4 (Latest Windows 64-bit build)
Worked: -

Short description of error

I have a specific file that when adding new objects in Local view the new objects do not have any layers assigned (as observed in the Object> Relations panel under Layers). The objects do get layers assigned upon exiting Local view.

I can't replicate this error with other files and it doesn't happen if I re-renter Local view after exiting it.

The file isn't mine (but I have permission to upload it) so I don't know the steps that were taken to create the scenario where this does happen, so I know this bug report may only be of limited use, but I thought I would report it anyway.

The problem came up on http://blender.stackexchange.com/questions/67940/cycles-render-result-doesnt-match-render-view when a user noticed that their renders (from within Local view) did not show all the objects that were visible in the viewport. The fix was to manually assign layers to the object or exit and re-enter Local view.

Exact steps for others to reproduce the error

  1. Open the file
  2. Add a new object, e.g. Shift+A> Mesh> Plane
  3. See that under Object> Relations> Layers the object isn't assigned a layer.
  4. Exit and re-renter Local view to see that new objects now get layers correctly assigned

Details

Type
Bug

Event Timeline

Yeah it is strange, the v3d->layact is binary 1000000000000000000000000 which has local view flag but no active layer set, so new object is only on local view. Switching almost anything and layact becomes normal. Can't really do much unless we can reproduce what makes it get screwed up.

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.Nov 30 2016, 9:08 AM

Yep, we need way to reproduce that issue, otherwise this is mere glitch (and an easy to solve one even)…

Bastien Montagne (mont29) claimed this task.

More than a week without reply. Due to the policy of the tracker archiving for until required info/data are provided.