Page MenuHome

Blender, Versions 2.77 & later insist on OpenGL 2.1 compliant video card as MANDATORY and refuse to do ANYTHING without such graphics system present
Closed, InvalidPublic

Description

Blender, Versions 2.77 & later insist on OpenGL 2.1 compliant video card as MANDATORY and refuse to do ANYTHING without such graphics system present. Futhermore, the Linux version, once an attempt to execute Blender is made, can afterwards exhibit unpredictable system behavior when executing certain other software programs.
While full software rendering is an option once Blender is running, this situation is a Catch-22: Nobody can choose full software rendering unless Blender is executed first, which is impossible on systems without a full OpenGL 2.1 compliant graphics system installed--period.

Event Timeline

The OpenGL 2.1 is currently required to run the most recent builds of Blender.

https://www.blender.org/download/requirements/

You can use version 2.76 and earlier if you system doesn't meet the above requirement. You can download previous versions of Blender here: http://download.blender.org/release/

This is not a bug.

Think this is about not being able to use softwareGL on machines that don't support OpenGL2.1 which is indeed a bit stupid. @Mike Erwin (merwin) is it possible to do a runtime check for softwaregl?

Mike Erwin (merwin) lowered the priority of this task from Unbreak Now! to Low.Dec 1 2016, 6:46 PM

I attempted an automatic software GL fallback on Mac for 2.78, but it never quite worked. See T47630 for more info & some test builds.

You can activate software rendering on Mac via the Terminal:
export BLENDER_SOFTWAREGL=1
open /Applications/Blender.app

@Casey Ennis (caseyennis) see if that meets your needs or if 2.76 is better.

Brecht Van Lommel (brecht) changed the task status from Unknown Status to Invalid.Jul 20 2017, 4:56 PM
Brecht Van Lommel (brecht) claimed this task.

This bug report appears to be about Linux, where users can execute blender-softwaregl. Enabling software OpenGL does not require running Blender, in fact it is not in the user preferences at all, so there is no catch-22.