Page MenuHome

Blender does not work above 1920x1080
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 8.1
graphics card: Amd Radeon R7

Blender Version
Broken: all versions (several versions tested, 32 bits and 64 bits, including 2.78a)
Worked: all versions if display resolution is set to 1920x1080 or lower

Short description of error
If display resolution is set to 1920x1080 or lower, Blender Works well. If resolution is any available higher resolution (my screen supports upto 4K, 3840x2160) Blender does not start.
Starting from cmd window, I see 2 messages when working (at low resolution), but just 1 message when not working (at high resolution).
Message 1:
AL lib: <EE> UpdateDeviceParams: Failed to set at 44100hz, got 48000hz instead
Message 2:
found bundled Python: C:\Data\Blender\2.78\python

Tested on a virtual machine using VMWare Virtual Box with Ubuntu 16.04, several versions of Blender, all versions work well at 4K resolution.

Exact steps for others to reproduce the error
I don't know

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

This is most certainly a GPU/driver issue, so first of all we'll need the exact GPU and driver versions. Also please:

  • Ensure both your OS and drivers are fully up-to-date (and use official GPU drivers, not those provided by windows or tablet/laptop maker).
  • Try the latest build from our buildbot.
  • Try to start Blender in factory settings (--factory-startup commandline option) (this will ensure whether this is a userpref or addon issue or not).
  • Try to tweak OGL settings in UserPreferences, System tab.
  • Try to tweak your GPU driver settings (e.g. try different values between 'performance' and 'quality' if you have such slider, etc.).
  • Attach as text file here the report generated by Help -> System Info (do not paste it directly in comment).
  • Launch Blender from the command line with -d option and attach as text file here any error printed out in the console (do not paste it directly in comment).
  • Try to place this dll next to your blender.exe (software OGL, will be slow, but will show whether this is a driver issue or not).

I also think it is a GPU/driver issue, as it works well on the virtual machine (Ubuntu under VMWare Virtualbox), but I'm unable to discover how to solve it and I wonder why opengl32.dll does not solve it. The graphic card is 'AMD Radeon(TM) R7 Graphics' (from ATI Technologies), and the driver versión is '4.4.12874' (also tested with several previous versions).

  • Both Windows OS and Graphics drivers are updated.
  • Tried the latest build with same results.
  • Factory settings did not solve it.
  • Tried a bunch of settings, in both my graphic card driver and blender preferences, with no results.
  • System info file:
  • Console output:
  • opengl32.dll did not solve the issue.
Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Normal.

Thanks for testing, am pretty short on idea here, maybe our OGL gurus around have more interesting hints, @Mike Erwin (merwin)? @Dalai Felinto (dfelinto)?

That's very odd. I used to run Blender 2.77 at work on a 4K monitor with no problems (Windows 10 & Geforce 970). Hopefully the problem is limited to this particular GPU.

@Blas Soriano (Namerutan) also try with the --debug-gpu option. Maybe a new clue will show up.

I have an AMD A10-7850K, very similar to @Blas Soriano (Namerutan)'s A10-7800. I'm running Windows 10.

renderer:	'AMD Radeon(TM) R7 Graphics'
vendor:		'ATI Technologies Inc.'
version:	'4.5.13431 Compatibility Profile Context 16.150.2211.0'

Platform #1
	Platform Name: AMD Accelerated Parallel Processing
	Platform Vendor: Advanced Micro Devices, Inc.
	Platform Version: OpenCL 2.0 AMD-APP (2004.6)
	Number of devices: 2
		Device: #0
			Device Name: Spectre
			Device Vendor: Advanced Micro Devices, Inc.
			Device Version: OpenCL 2.0 AMD-APP (2004.6)
		Device: #1
			Device Name: AMD A10 PRO-7850B R7, 12 Compute Cores 4C+8G   
			Device Vendor: AuthenticAMD
			Device Version: OpenCL 1.2 AMD-APP (2004.6)

Have no hi-res monitors here so I will visit a friend in the next few days & use theirs.

Tried --debug-gpu, same result. Attached txt from console output, using high and low resolution:

Found a posible reason why it Works on the virtual machine: the graphics driver is a virtual driver.

From system-info using Blender for Linux over Ubuntu on Virtualbox:

OPENGL

renderer: 'Gallium 0.4 on llvmpipe (LLVM 3.8, 128 bits)'
vendor: 'VMWare, Inc.'
versión: '3.0 Mesa 11.2.0'

I will try to launch a Live sesion to test Blender directly over Ubuntu.

On a live sesion using blender for linux over Ubuntu 16.04, system/info throws similar info than using a virtual machine>

OpenGL:

renderer: 'Gallium 0.4 on AMD KAVERI (DRM 2.43.0, LLVM 3.8.0)'
vendor: 'X.Org'
version: '3.0 Mesa 11.2.0'

I hope that will give you some clues on how to solve my issue on Windows.

Can Blender run on Intel HD Graphic 5500? I plan to learn Blender now but very confuse about which notebook should I buy?

Can Blender run on Intel HD Graphic 5500? I plan to learn Blender now but very confuse about which notebook should I buy?

Yes @Anthony (BlenderNoob91), the HD 5500 can do OpenGL 4.4 so will run the latest Blender (and also the next few versions). Enjoy learning!

can anyone help me, i can't find diffuse BSDF on material.

@Anthony (BlenderNoob91) This is a general support issue and not a software error we can investigate.

For general issues, check on support sites such as:

The issue reported can't be reproduced so far, and has been moved to the BF Blender: Unconfirmed project.
If 2 other people aren't able to redo the bug after 2 weeks, it will be closed.

We appreciate the effort that goes into making bug reports, but to be able to fix bugs we have to be able to redo them.
If there is anything you can provide to help others to reproduce the problem, be sure to include it.

Aaron Carlisle (Blendify) closed this task as Archived.Jun 29 2019, 2:52 AM
Aaron Carlisle (Blendify) claimed this task.