FBX Export Scaling Wrong
Closed, ResolvedPublic

Description

System Information
Win10 x64, nVidia GTX 780

Blender Version
Broken: all latest builds from Buildbot
Worked: 2.77, 2.78a

Short description of error
If I export the simple default cube (2m in diameter if you set Blender to "Metric") to FBX with default settings and import this file in Blender again, the cube now is 2cm in size. The cube's scale is set to 0.01.

If I import the very same cube exported from e.g. Blender 2.77 or 2.78 it comes in at the right scale.

I noticed that if I uncheck the "EXPORT_SCENE_OT_fbx.apply_unit_scale" option in the exporter the cube gets exported with the right scale in the latest build as well.
In previous versions the cube gets exported at the right scale no matter if this option was on or off.
Looks like a regression in the FBX exporter.

Exact steps for others to reproduce the error

  • add a default cube
  • export as FBX with default settings
  • import this FBX and it's tiny

Details

Type
Bug
Bastien Montagne (mont29) triaged this task as "Confirmed" priority.

Most certainly caused by rBAafeee1999, will check.

So, can you please download https://git.blender.org/gitweb/gitweb.cgi/blender-addons.git/snapshot/be617f7a2c1ebbb41d9ac96b932b439d4a2d5dcd.tar.gz and replace your current FBX addon directory content by what's in that archive? it's an attempt to rework (yet again :/ ) scaling handling in the exporter, you know have fours choices to apply custom and unit scaling either fully locally, fully as an FBX scale, or mixes of both.

Let me know if any of those four options work as you'd expect.

Wow! That looks great. I don't have much time to test all kinds of combinations but following the repro steps in this bug report gave me the results I expected:

Export with default options -> Import with default options -> same scale, all is great! :)

Bastien Montagne (mont29) closed this task as "Resolved".Jun 16 2017, 4:00 PM

Thanks, committed in master addons as rBA8b2a241baca09c9ae.