Page MenuHome

Blender runs super slow after nVidia Driver Update
Closed, ResolvedPublic

Description

System Information
Windows 10 64bit
NVIDIA GeForce 940MX

Blender Version
Broken: 2.78a
Worked: 2.78a

Short description of error
The blender app worked perfectly, it ran 100% correctly and I had no problem. I made an update to the NVIDIA driver a day ago and I tried opening blender today and it was soooooo slow. I have no idea why. As my CPU I have Intel i5 7th Gen. Blender ran just fine when I had it running on the CPU's graphics too but right now it doesn't. I have tried the portable version and the installer on 64bit.

Exact steps for others to reproduce the error
Not really any steps. I just updated the driver and that was all. Other apps work just fine.

Details

Type
Bug

Event Timeline

Hi Agustín.

I have the same problem, but I've discovered it's due to the NVidia driver, not Blender.
Try opening the NVidia Control Panel, then go to "Manage 3D settings (in Spanish "Controlar la configuración 3D") &, in Global Settings, change the Prefered graphics processor to the onboard graphics card. I did it & it works as usual. Of cours, that's not ideal, but untill next driver is released, it's a solution.

Hope that helps.
Marcelo.

This task is the same/ similar as T49758, T50154 and T50142.

Since it is a driver problem, I'm afraid that there is not much we can do.

In addition to the previous advice, try possible workarounds from this post, if that doesn't work try to install an older driver that did.

Closing as archived.

Jakub Zolcik (sftd) reopened this task as Open.EditedDec 11 2016, 1:45 PM

Hi,

This task is the same/ similar as T49758, T50154 and T50142.

I'm not sure if you are not mixing 2 issues into one. That's why I will describe my experience here, not in T49758.

I also stumbled upon Blender UI dramatically slowing down and making it unusable. But it was only after Nvidia drive update not more than 2 weeks ago (to v376.19). Workarounds from the other task do not work for me. What's more previous versions of Blender work fine (latest working release is v2.72b, v2.73 is unusable with latest drivers). That's why I'm not sure it's "entirely" drivers fault (despite the fact that rolling driver back fixes the issue).

I'm mentioning all of it because I think this problem is being treated to lightly. It might be a really bad experience especially for new users.

If I'm wrong then sorry for the trouble.

Edit:

Tested on:
Window 10, 64bit
GTX 765M

Jakub Zolcik (sftd) closed this task as Resolved.Dec 15 2016, 5:23 PM

For me problem was fixed with driver 376.33.

I'm having similar issues to it being very slow, I'm running an i7-4810mq CPU with an NVidia 860m. As other users have mentioned - everything else works perfectly well, including 3dsmax, composite, digital fusion etc.

I am a new user to blender wanting to try it out and have been learning on other machines as this one cannot be used, even rotating the default viewport with just a cube is painfully slow.