Page MenuHome

Is glossy ray broken in light path node
Closed, ArchivedPublic

Description

System Information
Ubuntu 16.10 x64 geforce gtx 1070
Windows 7 x64 geforce gtx 960

Blender Version
Broken: 2.78a x64 win & lin, current buildbot 62a2ed9 win x64

Short description of error
"Is glossy ray" will not switch the color of the emission shader on the sphere in the following simple setup of a cube with glossy shader and a plane with diffuse shader:


Turning off "Glossy" in the ray visibility settings works as expected, though.

Exact steps for others to reproduce the error
Open attached .blend:


Render

Details

Type
Bug

Event Timeline

It works as expected with low roughness of mirror surface:

It seems roughness setting gradually change "Glossy rays" into the "Diffuse rays". If so then it seems to me quite logical

Sergey Sharybin (sergey) closed this task as Archived.Dec 9 2016, 2:19 PM
Sergey Sharybin (sergey) claimed this task.

Thanks for the report, but this is a known limitation. Light path node doesn't work for lamps because they are evaluated for all the closures.

This might be changed in the future, but is quite tricky to do it without slowing things down.