When updating render percentage, viewer nodes aren't updating correctly for mask size
Open, NormalPublic

Description

I ran into a confusing issue the other day that made me log bug T50113, thinking there was an issue related to masks and render size, but it turns out the issue is in the viewer node not updating correctly when adjusting render size.

If you look at this animated gif:

http://www.giphy.com/gifs/l2JhONGhmXbzdvOLu

you can see that as I change the render percentage and update a value in the compositor, the result in the viewer changes so the mask is not consistent.

If I were to re-render the scene, the mask would appear relative.

Unfortunately, since the viewer updates and displays the incorrect information, this can be confusing to the user and cause them (me) to freak out and try and adjust things that don't need to be adjusted. For example, I ended up changing my mask values over and over again, never achieving the correct result.

Details

Type
Bug

Thanks for the report, please provide a blend file for testing.

Aaron Carlisle (Blendify) triaged this task as "Incomplete" priority.Feb 2 2017, 5:32 PM
Joey Ferwerda (TheOnlyJoey) closed this task as "Invalid".Feb 9 2017, 4:26 PM
Joey Ferwerda (TheOnlyJoey) claimed this task.

Report has not been reacted on for 7 days, closing due to bug tracker policy.

Sorry, I've been away and haven't had time to update this. I'm attaching a file demonstrating the problem.

Joey Ferwerda (TheOnlyJoey) raised the priority of this task from "Incomplete" to "Needs Triage".Feb 9 2017, 7:34 PM
Aaron Carlisle (Blendify) triaged this task as "Normal" priority.