Blender - Ardour timecode off by 1 to 4 frames when synced via JACK transport
Closed, InvalidPublic

Description

I'm using Ardour with Blender synced to JACK transport to edit video and audio at the same time. I've noticed that the timecode shown by both programs doesn't quite match at all times.

What is strange - when Blender and Ardour use the same framerate: 24 or 30 FPS - the indication is often off by 4 frames.
When Ardour uses 30 FPS, and Blender uses 24 FPS - the indication is off by only 1 frame.

I recorded two short videos to show this problem:

https://youtu.be/_c1xYQUtwI0
https://youtu.be/2F0syzgdsI0

I also created an issue in Ardour bugtracker - I don't know if Ardour or Blender is causing the TC error.

http://tracker.ardour.org/view.php?id=7167

Details

Type
Bug

Nice report @Tobiasz Karoń (unfa). I see two things here: the first thing is the difference of one off, which I could reproduce and is a bug of ardour and the other one I couldn't reproduce and is cause by blender.

You can check this by doing the following: move single frames in blender by using your cursor keys (left, right) over the sequence editor window. In ardour you can see that sometimes the frame is one off, sometimes not. But in the second window which shows the bars/ticks you can see the number to the right always changing by the same amount for each frame. The exact amount it changes of course depends on the meter and frame rate settings. While this number is accurate though, there seems to be a rounding problem for the frame number.

The second problem which I could not reproduce is the 4 frames off. This looks like a blender bug because it happens at 24 frames in ardour (and blender!?) but apparently blender still seems to display the times with 30 frames per second. I saw a few times that even though it was set to 24 frames, blender showed numbers above 23 (=> 24-29) which of course is impossible with 24 frames per second. Also the difference between ardour showing the (almost) correct frame number and blender makes sense, for example you had frame 19 in ardour and frame 23 in blender: 19 / 24 * 30 = 23.75, so the difference you can achieve with this displaying bug is up to 6 frames (30-24). However, as stated I couldn't reproduce this bug and in any case it's a UI bug in the VSE, so I'm putting this report up for grabs. Lastly let me add, that it would be interesting to see what the timeline shows, but in the videos it's not zoomed out, so you can't see the playback head there. If correct it should show the frame (seconds * framerate + subframe).

Aaron Carlisle (Blendify) triaged this task as Incomplete priority.Feb 2 2017, 7:21 AM

@Joerg Mueller (nexyon) what is the final verdict here?

Joerg Mueller (nexyon) closed this task as Invalid.Feb 9 2017, 8:33 AM
Joerg Mueller (nexyon) claimed this task.

As there hasn't been a response for a week, I'm closing this. Feel free to reopen if the bug in Blender still persists.