Page MenuHome

node_wrangler does not load properly on blender startup so it cannot be used until disabled and reenabled
Closed, ResolvedPublic

Description

System Information
W7 x64, Gigabyte gtx 1070

Blender Version
Broken: (2.78a Hash: e8299c8)
Broken: (2.78 Hash: 4bb1e22)
Worked: (2.77 Hash: 22a2853)

Short description of error
node_wrangler does not load properly on blender startup so it cannot be used until disabled and reenabled.

Exact steps for others to reproduce the error
Open blender, enable node_wrangler addon, save the settings and close blender

Using default startup scene follow this steps

  1. Start blender
  2. Set cycles render
  3. Switch layout to compositing
  4. Enable nodes for Cube material in Node editor
  5. Add an ADD SHADER
  6. Try if ctrl+shift on ADD SHADER works in Node editor

it doesnt work even we previously saved configuration with addon enabled

  1. Go to UserPrefs and verify wrangler is TICKED. Untick (disable) it.
  2. Enable it
  3. repeat step 6

now it works

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.

Please also try the latest build from our buildbot.

I can't reproduce this - as Bastien suggests please try with a recent build.

My apology guys,

It came out that the problem was on my side. Every new version i have installed was still using the same config and a mistake in input configuration was causing wrangler not to work properly. I have restored inputs config for node editor and now it is working.

Thanks for you time and effort.

Paul

Fable Fox (fablefox) closed this task as Resolved.Dec 18 2016, 12:46 PM

Problem on user side.