Page MenuHome

Blender crashes when bringing in a texture node in compositor
Closed, InvalidPublic

Description

System Information
Linux Mint 18/Ubuntu 16.04; GTX1080; Xeon CPU

Blender Version
Broken: 2.78a 2016-10-24 12:20
Worked: (optional)

Short description of error
Blender crashes with Segmentation Fault error when bringing in a texture node into the compositor.
Exact steps for others to reproduce the error

  1. Go to node editor and change to compositor window
  2. Bring in a texture node from the Inputs menu
  3. Watch the crashy goodness :)

blender.crash.txt provides the following details:

Blender 2.78 (sub 0), Commit date: 2016-10-24 12:20, Hash e8299c8

bpy.context.area.type = 'NODE_EDITOR' # Property
bpy.context.space_data.tree_type = 'CompositorNodeTree' # Property
bpy.context.scene.use_nodes = True # Property
bpy.ops.node.add_node(use_transform=True, type="CompositorNodeTexture") # Operator

backtrace

blender(BLI_system_backtrace+0x1d) [0x1b631ad]
blender() [0x11bbcfe]
/lib/x86_64-linux-gnu/libc.so.6(+0x354b0) [0x7fd81500b4b0]
blender(_ZN20TextureBaseOperation19executePixelSampledEPfff12PixelSampler+0x74) [0x17d1994]
blender(_ZN16PreviewOperation13executeRegionEP4rctij+0xee) [0x17d54ce]
blender(_ZN9CPUDevice7executeEP11WorkPackage+0x37) [0x17b1dd7]
blender(_ZN13WorkScheduler18thread_execute_cpuEPv+0x2d) [0x17b0d8d]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x76ba) [0x7fd8166056ba]
/lib/x86_64-linux-gnu/libc.so.6(clone+0x6d) [0x7fd8150dc82d]

Details

Type
Bug

Event Timeline

Vuk Gardašević (lijenstina) closed this task as Invalid.

This task is a duplicate of T49857.
Should be resolved by the commit rB534f11f71ee7 from November 3rd.

Please try the latest build from https://builder.blender.org/download/