Cycles allows to select un supported GPUs for OpenCL
Open, ConfirmedPublic

Description

System Information
macOS Sierra and Intel Iris 6100

Blender Version
Broken: 2.78

Short description of error
I tried to render by selecting OpenCL on user preferences and selected GPU compute accordingly in render options. But Blender halts by showing Loading render Kernels

Exact steps for others to reproduce the error
->Go to user preferences select OpenCL as for render.
->Select GPU compute in render options.
->Press shift + z to enter in render mode.

Details

Type
Bug
Aaron Carlisle (Blendify) changed the title from "Unable to render on OpenCL" to "Cycles allows to select un supported GPUs for OpenCL".Dec 27 2016, 6:35 PM
Thomas Dinges (dingto) closed this task as "Archived".Dec 27 2016, 8:14 PM
Thomas Dinges (dingto) claimed this task.

Intel GPUs are not officially supported yet for Cycles rendering. This might change in the future, with various split kernel improvements, but for now it's a known limitation.

@Thomas Dinges (dingto) I do not think that the Intel GPU should show up? Or is there no way of determining this?

We explicitly white list certain OpenCL configurations, not sure we differentiate correctly on OSX though.

Sergey Sharybin (sergey) reopened this task as "Open".Dec 28 2016, 11:16 AM
Sergey Sharybin (sergey) triaged this task as "Confirmed" priority.

We don't officially support Iris due to compiler limitations. We should only white-list AMD cards by default on all platforms. It should be possible to get device name on platform Apple and black-list Iris in ccl::OpenCLInfo::device_supported().

Wouldn't want to blindly apply changes without test here. So unless someone handles this will do it when i'm back to studio.

Add Comment