Page MenuHome

OpenCL error
Closed, ResolvedPublic

Description

System Information
Windows 10 x64
AMD Radeon HD 7770

Blender Version
Blender 2.78a

I open a default startup file, and when I go to render it with cycles and GPU it take me this error:

In Blender 2.78.4 I'm making the same thing, and Blender take me this:

BUT if I render in viewport, or check "Progressive Refine" It render OK.

Please help me.

Details

Type
Bug

Event Timeline

Which drivers you have installed?
I have similar issues with latest Crimson ReLive drivers.

https://developer.blender.org/T50082
https://developer.blender.org/T50082

Hi Max!

I had the same issue and it already fixed in daily builds. You need to change that 'D->z' to '(*D).z' in line 238 in file kernel_projection.h .

But it also probably pointing out to dated AMD graphics driver on your pc. Because with AMD GPU Pro 16.40 graphics driver for Linux that issue not happens for me. Probably newest AMD graphics driver for Windows also have no troubles with 'D->z'.

soulfire (vejn) added a comment.EditedDec 19 2016, 4:44 PM

I had the same issue and it already fixed in daily builds. You need to change that 'D->z' to '(*D).z' in line 238 in file kernel_projection.h .
But it also probably pointing out to dated AMD graphics driver on your pc. Because with AMD GPU Pro 16.40 graphics driver for Linux that issue not happens for me. Probably newest AMD graphics driver for Windows also have no troubles with 'D->z'.

Hi, Alexander. I have AMD 7870, Crimson Relive drivers, blender-2.78-6c3d8fb 19.Dec

my line is
float altitude = fabsf(safe_asinf((*D).z));

When I open scene, viewport rendering is ok. Then if I render image, open cl error appears.
After I close console log, Blender crashes.

Alexander, do you know what would be the issue?

Which drivers you have installed?
I have similar issues with latest Crimson ReLive drivers.
https://developer.blender.org/T50082
https://developer.blender.org/T50082

I have 16.11.5 version installed.

Hi,
I´m having same issue and error. Driver version 16.11.4 - Crimson edition.
Blender version 2.78a
HW: 4x R9 200 series

Max, please try latest daily build, so Blender devs will not waste time to investigate things that they already solved. I'm not Blender dev - so it's only my humble proposition.

Greetings to you, Tom.

At first I wanted to notice your inconsistency, but just see that you are different person, not the author of that bug report :)
I have very different config (AMD R9_290, AMD GPU Pro 16.40 driver and Linux x64) and I can't reproduce your issue neither with Blender 2.78a nor with today's daily build 2-78-bd42987.

But it looks like you are out of GPU's memory (these allocation errors and crash thereafter). Are you sure that your scene fits into your GPU's memory? You are rendering not default cube scene as Max, right? If your monitor attached to the same HD 7870, than you have not all GPU's memory at your disposal. For my case it is 3.5Gb instead of full 4 Gb.

But if you are talking about 'ps test.blend' from your bug report T50082, than it is rendering ok for me with any combination of 'motion blur' and 'progressive refine' options. And it takes quite a token amount of memory, just about 30Mb - 50Mb (looking at 'Frame | Time | Mem' string after render).

At first I wanted to notice your inconsistency, but just see that you are different person, not the author of that bug report :)

I apologize.
I think that the source of the issue lies in the Windows drivers for any 7xxx card.

But it looks like you are out of GPU's memory (these allocation errors and crash thereafter). Are you sure that your scene fits into your GPU's memory? You are rendering not default cube scene as Max, right? If your monitor attached to the same HD 7870, than you have not all GPU's memory at your disposal. For my case it is 3.5Gb instead of full 4 Gb.

I have 2GB GPU RAM. I'm rendering scene which is below that memory. Even the startup scene with the cube is giving the same opencl error.

Mai Lavelle (maiself) closed this task as Resolved.Jan 6 2017, 12:19 PM

Issue in origial report has been fixed in master, closing as resolved.