Problems (yet again) with Linked Objects that have Alembic Cache applied
Closed, ArchivedPublic

Description

System Information
Win7 SP1

Short description of error
I'm on the latest nightly build and still there are some showstopping issues with linked objects that have alembic cache files applied to them. If you retime the cache via the override Frame option on the original file to be linked, the animation on the linked files goes poof.

Exact steps for others to reproduce the error
Open the provided scene file. (

)
Retime one of the objects' cache via override frame and save over.
Link in the group that contains the object you retimed previously into a new scene.
Scrub and see nothing happening.

You can return to the provided file, uncheck override frame and relink to see that the default animation from the abc file functions. It is the frame override that gets unread once checked and animated.

Details

Type
Bug

@Ajlan Altug (jacobo) can't reproduce issue, but it may be due to missing alembic file?

Bastien Montagne (mont29) triaged this task as "Incomplete" priority.Jan 9 2017, 12:01 PM

Aaarrghhh... Silly silly meee :) Sorry for this. Here it is:

There is no bug here, if you tick the Override Frame check box, it will use the provided frame number from the Frame field to lookup the cache. If you want to overwrite the animation over time you need to set some key frames on the Frame field.

I tried to override the frame with and without key frames and linking it in a new Blender file, and each time the result was the expected one (without keys -> static, with keys -> animation).

Either there is no bug or I am not understanding either the issue or how linking works.

Joey Ferwerda (TheOnlyJoey) closed this task as "Archived".Feb 9 2017, 4:30 PM
Joey Ferwerda (TheOnlyJoey) claimed this task.

No reaction from the original commenter on last reaction for a while, archiving.