Page MenuHome

Matcap display error on version 2.78a
Closed, ArchivedPublic

Description

System Information
Operating system and graphics card
Windows 7 - Service Pack 1 - Home Premium with AMD E2-3200 APU with Radeon(tm) HD Graphics 2.40GHz
Graphics updated, CPU only (as far as I can tell)

Blender Version
Broken: 2.78a | Hash: e8299c8 | 2016-10-24 12:20

Worked: 2.77a | Hash: abf6f08 | 2016-04-05 18:12

Short description of error
The Matcap does not display properly. When using the Matcap the object displays white with a yellow trim around it. This happens regardless of whether GLSL or Multitexture is used. And happens regardless of whether I am in blender render or cycles. All the matcaps were tried and had the same problem. I downloaded a fresh copy of blender to confirm the issue was in the official released version.

The last version that the Matcaps properly displayed was 2.77a the version right before this.

Exact steps for others to reproduce the error
Based on (as simple as possible) attached .blend file with minimum amount of steps

  1. Download fresh copy of blender 2.78a
  2. apply matcap to any object.
  3. error

Details

Type
OpenGL Error

Event Timeline

Aaron Carlisle (Blendify) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Jan 5 2017, 7:46 PM

Its highly likely that this bug is specific to your hardware/driver configuration.
These kinds of display issues are often caused by OpenGL driver bugs.

While its possible a software error in Blender,
its worth checking if this functions correctly...

  • After upgrading graphics card drivers.
  • On a different system (with different hardware/drivers).
  • Using a Software OpenGL renderer...
    • On Linux, Official releases come with blender-softwaregl
    • On MS-Windows: Downloading 'opengl32.dll' from download.blender.org/ftp/sergey/softwaregl and copying it so its located in the same directory as 'blender.exe'

If this is a driver bug, or we can't link to this to an error in Blender's code,
the report may be closed as a driver error,
so please help us determine whether this is a bug in Blender or not.

Mike D (blendstones) added a comment.EditedJan 5 2017, 11:09 PM

Hello Aaron. I used the "opengl32.dll" that you recommended and that fixed the display problem. But blender now has a heavy lag immediately after adding that file to the folder. Because the lag is so incredibly heavy I can't see this as a viable solution to the problem, unfortunately.

Note:
I am not so sure that this is a bug with my drivers because I downloaded a fresh install of blender 2.77a today and it works perfectly. All versions prior work as well (downloaded specifically to test). But a fresh install of blender 2.78a gives me the display error.

I would imagine that a driver bug would display on both versions of blender if the error was due to my driver. That is why I firmly believe that a change must have occurred within blender to create this bug.

Thanks

Aaron Carlisle (Blendify) claimed this task.

When using the dll it by passes both your GPU and GPU driver and renders everything on you CPU and using something called software OpenGL. Because it works on software OpenGL and not the hardware OpenGL means that the issue is with your hardware. One possible reason why 2.77a works is because error like this occur when we update the OpenGL drawing code. SO thanks for the report but it is an issue on your side, try updating you driver or get a new GPU.

JC Weatherby (JCWeatherby) reopened this task as Open.EditedMay 4 2017, 1:32 PM

I'm having this same issue with 2.78c.

Even with the most up-to-date drivers for my GPU, this error still occurred.

Likewise, introducing this .dll file to blender.exe folder introduced a lag which MADE BLENDER UNUSABLE.

Given that the last "problem free" version was Blender 2.77a, that driver updates and the "opengl32.dll" dont really fix the problem, I am inclined to say it's an issue Blender Devs should address.

I have a totally new machine:

AMD / ASUS:

Ryzen 1800x
ASUS X370 chipset
Radeon WX7100 Pro (most recent driver, dated April 27, 2017)
Win 10
Blender 2.78c

Thank you!

Aaron Carlisle (Blendify) lowered the priority of this task from Needs Information from User to Confirmed, Low.May 4 2017, 4:15 PM
Aaron Carlisle (Blendify) changed Type from Bug to OpenGL Error.

I can confirm the same specs with the same matcap issues. I have a brand new WX 7100 Pro card with the latest drivers installed today.

Windows 10
Blender 2.78c

I don't think there's a fixable solution with a current driver from AMD, any way to catch that an AMD card is in use and attempt to compensate on the Blender side?

I can reproduce the issue here. It happens only on Windows, same card on Linux runs fine

That said, I can't get a working matcap even with 2.77a. Can someone that has matcap working in 2.77a let me know the exact driver version you are using?

Dalai Felinto (dfelinto) closed this task as Archived.May 31 2017, 6:04 PM

And the problem is solved with an updated driver.

I installed the beta driver from http://support.amd.com/en-us/download/workstation?os=Windows%2010%20-%2064#

https://www2.ati.com/drivers/firepro/win10-64bit-radeon-pro-software-17.10-apr11.exe

And it works fine. Closing for now.

Confirmed: matcaps displaying in Blender 2.78 with AMD wx7100 Pro, with June 2017 Driver Update.

Thank you!

Thanks so much for sharing the link!!!