Page MenuHome

Editor window changes its ratio by dragging Blender small and big
Closed, ArchivedPublic

Description

System Information
Operating system and graphics card

Windows 7 64 Bit

Blender Version
Broken: (example: 2.69.7 4b206af, see splash screen)
Worked: (optional)

Short description of error

Specific Editor window changes its ratio by dragging Blender small and big. Means, Blender is maximized, you turn it windowed and drag it small. And when you maximize Blender again, then the formerly closed editor window is now wide open. See screenshots.

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

I stumbled across this behavior when i wanted to place the Timeline below the Info editor at the top. And started to wonder why i now every now and then had to pull the Timeline editor up so that it is closed again.

Add another Editor type below the Info toolbar. Drag it up so that it shows closed and just the header is visible. Now drag Blender smaller. Then drag it bigger again. You will notice that the editor window where just the header should be visible now opens more and more up. Other areas keeps their ratio though.

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) closed this task as Archived.Jan 9 2017, 12:00 PM
Bastien Montagne (mont29) triaged this task as Confirmed, Medium priority.
Bastien Montagne (mont29) claimed this task.

Yeah… honestly, I do not consider this as a bug, at worst a minor glitch. Thing is, when reducing UI that much, you are reaching 'zero size' for some areas, where proportions cannot be preserved. It’s worse on vertical direction due to fixed size of header. Maybe this can be fixed somehow, but am pretty sure this won't be trivial, and really think it’s not worth the time. Thanks for the report anyway.

Hm. To drag it down to its minimum size is just the worst case to show the problem most clearly. This "minor" glitch causes me now to drag the title bar around every time i change the size of the Blender window. And it's enough to drag it just a few pixels around to make it visibly open up.

But it's of course your decision what to fix and what not. Thanks for investigation.