Fluid sim broken when domain/fluid are at large coordinates
Open, ConfirmedPublic

Description

System Information
Windows 7 / NVidia GeForce GTX 960

Blender Version
Broken: 2.87a e8299c8

Fluid simulation brakes/crashes/calculates forever when the domain/fluid are placed on large coordinates. In my case I use a unit scale is metric/0.01 and my domain/fluid are at x:-57m y:-13m z:8m (meter not cm!) but you can reproduce the issue using unit scale none/1.0 and placing both objects at x:-5700 y:-1300 z:800.

Exact steps for others to reproduce the error

  1. Open Blender File
  2. Click Domain-Cube
  3. Click Physics-Tab
  4. Click Fluid > Bake

The simulation will not start or take forever (not changing from 0%).

The "fix": Set the domain-cube and the fluid-sphere to x:0 y:0 z:0 (or coordinates near the origin) and it will work. It seems that the really big coordinates brakes the fluid simulation.

Details

Type
Bug
simon (simonschreibt) edited the task description. (Show Details)
simon (simonschreibt) edited the task description. (Show Details)

Could reproduce the issue with a new blendfile and blender units setup. Domain has to be moved to -5700/-1300/-800 to get the same result.

simon (simonschreibt) changed the title from "Fluid sim broken when unit scale is metric/0.01 and domain/fluid are at large coordinates" to "Fluid sim broken when domain/fluid are at large coordinates".Jan 6 2017, 4:44 PM
simon (simonschreibt) edited the task description. (Show Details)
john peterson (bliblubli) closed this task as "Resolved".Jan 7 2017, 3:53 PM
john peterson (bliblubli) triaged this task as "Confirmed" priority.
john peterson (bliblubli) claimed this task.

Can confirm the bug. Is pretty annoying as it can't even be canceled. One has to kill the process to cancel it.

It seems to be a floating point precision limitation in raytracing around line 405 of elbeem/intern/solver_interface.cpp, causing an infinite loop.